summaryrefslogtreecommitdiffstats
path: root/audio/quodlibet/quodlibet.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--audio/quodlibet/quodlibet.SlackBuild24
1 files changed, 7 insertions, 17 deletions
diff --git a/audio/quodlibet/quodlibet.SlackBuild b/audio/quodlibet/quodlibet.SlackBuild
index 1d9c2e961c..2b4403ff1a 100644
--- a/audio/quodlibet/quodlibet.SlackBuild
+++ b/audio/quodlibet/quodlibet.SlackBuild
@@ -4,7 +4,7 @@
#
# Written by K.D.Hedger kdhedger@yahoo.co.uk
# Copyright 2016-2017 Edinaldo P. Silva, Rio de Janeiro, Brazil.
-# Copyright 2020-2022 Nick Smallbone, Gothenburg, Sweden.
+# Copyright 2020-2024 Nick Smallbone, Gothenburg, Sweden.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=quodlibet
VERSION=${VERSION:-4.5.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -52,20 +52,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -75,10 +61,14 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python3 setup.py install --root=$PKG
-find $PKG/usr/share/man -type f -exec chmod 0644 {} \;
mv $PKG/usr/share/man $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done