summaryrefslogtreecommitdiffstats
path: root/audio/nnls-chroma/use_system_vamp_sdk.diff
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--audio/nnls-chroma/use_system_vamp_sdk.diff12
1 files changed, 12 insertions, 0 deletions
diff --git a/audio/nnls-chroma/use_system_vamp_sdk.diff b/audio/nnls-chroma/use_system_vamp_sdk.diff
new file mode 100644
index 0000000000..664f9bda22
--- /dev/null
+++ b/audio/nnls-chroma/use_system_vamp_sdk.diff
@@ -0,0 +1,12 @@
+diff -Naur nnls-chroma-0.2.1/Makefile.linux nnls-chroma-0.2.1.patched/Makefile.linux
+--- nnls-chroma-0.2.1/Makefile.linux 2010-12-07 08:05:16.000000000 -0500
++++ nnls-chroma-0.2.1.patched/Makefile.linux 2011-05-30 22:46:39.000000000 -0400
+@@ -13,7 +13,7 @@
+ CXXFLAGS = $(ARCHFLAGS) -I$(VAMP_SDK_DIR) -Wall -fPIC
+ PLUGIN_EXT = .so
+ PLUGIN = $(PLUGIN_LIBRARY_NAME)$(PLUGIN_EXT)
+-LDFLAGS = -shared -Wl,-soname=$(PLUGIN) $(VAMP_SDK_DIR)/libvamp-sdk.a -Wl,--version-script=vamp-plugin.map
++LDFLAGS = -shared -Wl,-soname=$(PLUGIN) -lvamp-sdk -Wl,--version-script=vamp-plugin.map
+
+
+ $(PLUGIN): $(PLUGIN_CODE_OBJECTS)