summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
Diffstat (limited to 'academic')
-rw-r--r--academic/python3-scipy/README6
-rw-r--r--academic/python3-scipy/python3-scipy.SlackBuild44
-rw-r--r--academic/python3-scipy/python3-scipy.info6
3 files changed, 26 insertions, 30 deletions
diff --git a/academic/python3-scipy/README b/academic/python3-scipy/README
index 74833a79a7..d46b964786 100644
--- a/academic/python3-scipy/README
+++ b/academic/python3-scipy/README
@@ -17,11 +17,7 @@ must install it in advance of numpy and build numpy accordingly (see
the README to numpy's SlackBuild). Moreover, after installing scipy,
you have to install scikit-umfpack.
-If you need to build scipy for debugging, set DEBUG=y.
+If you need to build scipy for debugging, set DEBUG=YES.
NOTE: this is for Python 3. If you need Python 2 support, install
python2-scipy.
-
-This script installs scipy ver. 1.9.1, the last possible version for
-Slackware 15.0. Newer versions require a newer Cython (as a build
-dependency).
diff --git a/academic/python3-scipy/python3-scipy.SlackBuild b/academic/python3-scipy/python3-scipy.SlackBuild
index b1d8fe8de6..d66bb4c266 100644
--- a/academic/python3-scipy/python3-scipy.SlackBuild
+++ b/academic/python3-scipy/python3-scipy.SlackBuild
@@ -4,6 +4,7 @@
# Copyright 2016-2019 Serban Udrea <s.udrea@gsi.de>
# Copyright 2022 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -33,7 +34,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM="python3-scipy"
SRCNAM="scipy"
-VERSION=${VERSION:-1.9.1}
+VERSION=${VERSION:-1.11.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -46,9 +47,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -69,29 +67,31 @@ cd "$SRCNAM-$VERSION"
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-DEBUG=${DEBUG:-no}
-DEBUG=$(echo "$DEBUG"|cut -b 1|tr a-z A-Z)
-
-if [ "$DEBUG" = "N" ]
-then
- python3 setup.py install --root $PKG
- find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-else
- python3 setup.py build --debug
- python3 setup.py install --root $PKG
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Allow our version of pybind11 and numpy to work
+sed -i 's|<2.11.1|<=2.11.1|' pyproject.toml
+sed -i 's|numpy==1.21.6|numpy>=1.21.6|' pyproject.toml
+
+# needs newer meson
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
+
+# Skip stripping symbols if DEBUG is YES
+if [ "${DEBUG:-NO}" == "NO" ]; then
+ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.txt HACKING.rst.txt PKG-INFO \
+cp -a CONTRIBUTING.rst LICENSE.txt LICENSES_bundled.txt README.rst PKG-INFO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc -type f -exec chmod 0644 {} \;
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/academic/python3-scipy/python3-scipy.info b/academic/python3-scipy/python3-scipy.info
index aba0a79808..0a06f56c34 100644
--- a/academic/python3-scipy/python3-scipy.info
+++ b/academic/python3-scipy/python3-scipy.info
@@ -1,8 +1,8 @@
PRGNAM="python3-scipy"
-VERSION="1.9.1"
+VERSION="1.11.3"
HOMEPAGE="https://www.scipy.org/"
-DOWNLOAD="https://github.com/scipy/scipy/releases/download/v1.9.1/scipy-1.9.1.tar.gz"
-MD5SUM="e6e70a9014dba74b4ef16686d23fd3ad"
+DOWNLOAD="https://github.com/scipy/scipy/releases/download/v1.11.3/scipy-1.11.3.tar.gz"
+MD5SUM="9f618e66c4b12b702793cdfd2b7b3847"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-numpy lapack pybind11 python3-pythran"