summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python-dateutil/README5
-rw-r--r--python/python-dateutil/python-dateutil.SlackBuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/python/python-dateutil/README b/python/python-dateutil/README
index 5f9b6697e0..c3c1c52e58 100644
--- a/python/python-dateutil/README
+++ b/python/python-dateutil/README
@@ -1,2 +1,7 @@
The dateutil module provides powerful extensions to the
standard datetime module.
+
+Note: To install python3 bindings install six with python3
+bindings and pass PYTHON3=yes to the slackbuild.
+
+ # PYTHON3=yes ./python-dateutil.SlackBuild
diff --git a/python/python-dateutil/python-dateutil.SlackBuild b/python/python-dateutil/python-dateutil.SlackBuild
index 34a9ed81d2..594c674cee 100644
--- a/python/python-dateutil/python-dateutil.SlackBuild
+++ b/python/python-dateutil/python-dateutil.SlackBuild
@@ -64,6 +64,11 @@ done
python setup.py install --root=$PKG
+# Install python3 bindings. Default is no.
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true