summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/pygame/pygame.SlackBuild13
-rw-r--r--python/pygame/pygame.info6
-rw-r--r--python/pygame/setup.patch21
3 files changed, 34 insertions, 6 deletions
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
index 3792d996f3..90134bec34 100644
--- a/python/pygame/pygame.SlackBuild
+++ b/python/pygame/pygame.SlackBuild
@@ -6,7 +6,7 @@
# Modified by the SlackBuilds.org project
# Maintained by Bojan Popovic (bocke@slackware-srbija.org), 2014-2017
# Contribution by B.Watson (yalhcru@gmail.com), 11 apr. 2017.
-# Copyright 2017-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2017-2022 Dimitris Zlatanidis Orestiada, Greece
#
# All rights reserved.
#
@@ -30,7 +30,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pygame
-VERSION=${VERSION:-2.0.2}
+VERSION=${VERSION:-2.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,11 +80,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/setup.patch
+
+# Since portmidi 2.0.2, libporttime is included in libportmidi.
+# Therfore use config-settings like for Fedora.
+sed -i 's;/etc/redhat-release;/etc/slackware-version;' buildconfig/config_unix.py
+
# Contributed by B.Watson (yalhcru@gmail.com).
# Gets rid of the call to remove_old_files() during packaging.
# TLDR: Stops packaging scripts from messing with a local PyGame install.
sed -i '/^if "install"/,$d' setup.py
+# Pygame version 2.0.3 is the last that supports python2
python2 -u buildconfig/config.py
CFLAGS="$SLKCFLAGS" \
python2 setup.py install --root=$PKG
@@ -96,7 +103,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst docs/LGPL.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst docs/LGPL.txt docs/README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pygame/pygame.info b/python/pygame/pygame.info
index 4d599079bd..883b018c04 100644
--- a/python/pygame/pygame.info
+++ b/python/pygame/pygame.info
@@ -1,8 +1,8 @@
PRGNAM="pygame"
-VERSION="2.0.2"
+VERSION="2.0.3"
HOMEPAGE="http://www.pygame.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/01/45/06d6b0ba2abee5f5606f73ef9f10e95ba178eb63fa3f65f948a4863aac6b/pygame-2.0.2.tar.gz"
-MD5SUM="e94c1b7fff782a43c6dfeb726df8ae94"
+DOWNLOAD="https://files.pythonhosted.org/packages/47/a6/bd02c7354ac7e975e52443a24dbd0be8d071c59b75d54db9dfa87cd2979f/pygame-2.0.3.tar.gz"
+MD5SUM="04e082d216b3b771b8d52769597b2fb2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="portmidi"
diff --git a/python/pygame/setup.patch b/python/pygame/setup.patch
new file mode 100644
index 0000000000..687c758874
--- /dev/null
+++ b/python/pygame/setup.patch
@@ -0,0 +1,21 @@
+--- pygame-2.0.3/setup.orig 2022-02-20 22:52:08.449183353 +0200
++++ pygame-2.0.3/setup.py 2022-02-20 22:52:57.916188118 +0200
+@@ -75,7 +75,7 @@
+
+
+ # A (bit hacky) fix for https://github.com/pygame/pygame/issues/2613
+-# This is due to the fact that distutils uses command line args to
++# This is due to the fact that distutils uses command line args to
+ # export PyInit_* functions on windows, but those functions are already exported
+ # and that is why compiler gives warnings
+ from distutils.command.build_ext import build_ext
+@@ -95,6 +95,9 @@
+ the_system = 'Ubuntu'
+ elif distro[0].lower() == 'debian':
+ the_system = 'Debian'
++ elif distro[0].lower() == 'slackware':
++ the_system = 'Slackware'
++
+
+ help_urls = {
+ 'Linux': 'https://www.pygame.org/wiki/Compilation',