summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/mars/mars.SlackBuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/games/mars/mars.SlackBuild b/games/mars/mars.SlackBuild
index 52a64dbb4f..9db950fd9a 100644
--- a/games/mars/mars.SlackBuild
+++ b/games/mars/mars.SlackBuild
@@ -78,11 +78,17 @@ patch -p1 < $CWD/pull2.patch
# https://github.com/thelaui/M.A.R.S./pull/17
patch -p1 < $CWD/pull17.patch
+# Fix build with fribidi-0.19.7 ...
+FRIBIDIFLAGS=$(pkg-config --cflags fribidi)
+# ... and use our bloody cxxflags, thanks all the same
+sed -i \
+ -e 's/set(CMAKE_CXX_FLAGS "-s -O2")/set(CMAKE_CXX_FLAGS "-s ${CMAKE_CXX_FLAGS}")/' \
+ CMakeLists.txt
+
mkdir -p build
cd build
cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS $FRIBIDIFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
make