summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--development/gorm/README6
-rw-r--r--development/gorm/gorm.SlackBuild65
-rw-r--r--development/gorm/gorm.info8
-rw-r--r--development/gorm/slack-desc18
4 files changed, 97 insertions, 0 deletions
diff --git a/development/gorm/README b/development/gorm/README
new file mode 100644
index 0000000000..83b725f4e3
--- /dev/null
+++ b/development/gorm/README
@@ -0,0 +1,6 @@
+As part of the GNUstep project, Gorm is meant to be the counterpart to
+NeXT's Interface Builder. With Gorm designing tough and complex graphical
+interfaces for your applications can easily and quickly be done using drag
+and drop, powerful inspectors and teamwork with ProjectCenter.
+
+This requires gnustep-make, gnustep-base, gnustep-gui, and gnustep-back.
diff --git a/development/gorm/gorm.SlackBuild b/development/gorm/gorm.SlackBuild
new file mode 100644
index 0000000000..4866f6496b
--- /dev/null
+++ b/development/gorm/gorm.SlackBuild
@@ -0,0 +1,65 @@
+#!/bin/sh
+#
+# Written by Stefan Bidigaray
+#
+# Slackware build script for GNUstep's Gorm.
+#
+
+VERSION=1.2.8
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+if [ -r /usr/share/GNUstep/Makefiles/GNUstep.sh ]; then
+ . /usr/share/GNUstep/Makefiles/GNUstep.sh
+else
+ printf "/usr/share/GNUstep/Makefiles/GNUstep.sh does not exist... \n"
+ printf "Is gnustep-make installed? Exiting... \n \n"
+fi
+
+set -e
+
+PRGNAM=gorm
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCLAGS" make
+make DESTDIR=$PKG GNUSTEP_INSTALLATION_DOMAIN=SYSTEM install
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat COPYING > $PKG/usr/doc/$PRGNAM-$VERSION/COPYING
+cat README > $PKG/usr/doc/$PRGNAM-$VERSION/README
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -c n -l y $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/gorm/gorm.info b/development/gorm/gorm.info
new file mode 100644
index 0000000000..30fde0d3af
--- /dev/null
+++ b/development/gorm/gorm.info
@@ -0,0 +1,8 @@
+PRGNAM="gorm"
+VERSION="1.2.8"
+HOMEPAGE="http://www.gnustep.org"
+DOWNLOAD="ftp://ftp.gnustep.org/pub/gnustep/dev-apps/gorm-1.2.8.tar.gz"
+MD5SUM="6988f6845503d47fa32e1779a816e087"
+MAINTAINER="Stefan Bidigaray"
+EMAIL="teco.sb@gmail.com"
+APPROVED="rworkman"
diff --git a/development/gorm/slack-desc b/development/gorm/slack-desc
new file mode 100644
index 0000000000..33731eec62
--- /dev/null
+++ b/development/gorm/slack-desc
@@ -0,0 +1,18 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+gorm: Gorm (GNUstep Interface Builder)
+gorm:
+gorm: As part of the GNUstep project, Gorm (Graphical Object Relationship
+gorm: Modeller) is meant to be the counterpart to Apple's Interface
+gorm: Builder.
+gorm:
+gorm: GNUstep is part of the official GNU project. Visit:
+gorm: http://www.gnustep.org
+gorm:
+gorm: