summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--python/passlib/passlib.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/python/passlib/passlib.SlackBuild b/python/passlib/passlib.SlackBuild
index 635a64f4bc..54b24ce5a7 100644
--- a/python/passlib/passlib.SlackBuild
+++ b/python/passlib/passlib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for passlib
-# Copyright 2015-2016 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2017 Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true