summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Lockywolf <for_sbo.gpustat_2023-11-30@lockywolf.net>2023-11-30 22:38:25 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-11-30 23:00:38 +0700
commit05649a5b12a4a432b2f82d912cde4df1929dd376 (patch)
tree69a4405e6aa2341c530c91b5c7dcc6f48e29e2a5 /system
parentdf8cf1df4d088cc7d80cc1b7a91f72104e1787ea (diff)
downloadslackbuilds-05649a5b12a4a432b2f82d912cde4df1929dd376.tar.gz
slackbuilds-05649a5b12a4a432b2f82d912cde4df1929dd376.tar.xz
system/gpustat: Added (query and monitor GPU).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/gpustat/README18
-rw-r--r--system/gpustat/gpustat.SlackBuild97
-rw-r--r--system/gpustat/gpustat.info10
-rw-r--r--system/gpustat/slack-desc19
4 files changed, 144 insertions, 0 deletions
diff --git a/system/gpustat/README b/system/gpustat/README
new file mode 100644
index 0000000000..a3b0ccf4f5
--- /dev/null
+++ b/system/gpustat/README
@@ -0,0 +1,18 @@
+gpustat
+
+Just less than nvidia-smi?
+
+gpustat uses NVIDIA's official python bindings for NVML library
+(pynvml). As of now gpustat requires nvidia-ml-py >= 11.450.129, which
+is compatible with NVIDIA driver versions R450.00 or higher. Please
+upgrade the NVIDIA driver if gpustat fails to display process
+information.
+
+The GPU ID (index) shown by gpustat (and nvidia-smi) is PCI BUS ID,
+while CUDA uses a different ordering (assigns the fastest GPU with the
+lowest ID) by default. Therefore, in order to ensure CUDA and gpustat
+use same GPU index, configure the CUDA_DEVICE_ORDER environment variable
+to PCI_BUS_ID .
+
+This is a very simple program, you might want to add its output to
+some status bar, such as byoby, i3-bar, or xfce4-generic-monitor.
diff --git a/system/gpustat/gpustat.SlackBuild b/system/gpustat/gpustat.SlackBuild
new file mode 100644
index 0000000000..f0ebd7a7ab
--- /dev/null
+++ b/system/gpustat/gpustat.SlackBuild
@@ -0,0 +1,97 @@
+#!/bin/bash
+
+# Slackware build script for gpustat
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=gpustat
+VERSION=${VERSION:-1.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.md LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/gpustat/gpustat.info b/system/gpustat/gpustat.info
new file mode 100644
index 0000000000..6c90296a96
--- /dev/null
+++ b/system/gpustat/gpustat.info
@@ -0,0 +1,10 @@
+PRGNAM="gpustat"
+VERSION="1.1.1"
+HOMEPAGE="https://github.com/wookayin/gpustat"
+DOWNLOAD="https://files.pythonhosted.org/packages/79/c4/46d005aec3bf911cb030467d91e062a5386ff4a03e51874424cacc0f60c1/gpustat-1.1.1.tar.gz"
+MD5SUM="63ce9a815d1d252c231f32eecd2929fd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-nvidia-ml-py python3-psutil python3-blessed"
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.gpustat_2023-11-30@lockywolf.net"
diff --git a/system/gpustat/slack-desc b/system/gpustat/slack-desc
new file mode 100644
index 0000000000..b0b8176a93
--- /dev/null
+++ b/system/gpustat/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gpustat: gpustat (utility for querying and monitoring GPU status)
+gpustat:
+gpustat: A simple command-line utility for querying and monitoring GPU status.
+gpustat: This works with NVIDIA Graphics Devices only, no AMD support as of
+gpustat: now.
+gpustat:
+gpustat:
+gpustat:
+gpustat:
+gpustat:
+gpustat: