summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2024-09-24 04:27:19 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-09-28 06:54:26 +0700
commitda8a40a1f72374f969fe534e07ee916f21f944bc (patch)
tree776a5fe2a1ae7084a1f60df22ea2716acdd914e5 /system
parent8d795ea4196331bc86d4d9143cbfd398d285f20d (diff)
downloadslackbuilds-da8a40a1f72374f969fe534e07ee916f21f944bc.tar.gz
slackbuilds-da8a40a1f72374f969fe534e07ee916f21f944bc.tar.xz
system/slim: New maintainer, fix slimlock.conf.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to '')
-rw-r--r--system/slim/doinst.sh5
-rw-r--r--system/slim/slim.SlackBuild48
-rw-r--r--system/slim/slim.info4
3 files changed, 25 insertions, 32 deletions
diff --git a/system/slim/doinst.sh b/system/slim/doinst.sh
index f502caffe6..978345b561 100644
--- a/system/slim/doinst.sh
+++ b/system/slim/doinst.sh
@@ -1,16 +1,13 @@
config() {
NEW="$1"
OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
if [ ! -r $OLD ]; then
mv $NEW $OLD
elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
rm $NEW
fi
- # Otherwise, we leave the .new copy for the admin to consider...
}
config etc/slim.conf.new
+config etc/slimlock.conf.new
config etc/logrotate.d/slim.new
-
diff --git a/system/slim/slim.SlackBuild b/system/slim/slim.SlackBuild
index b05bd1afa8..7ec45fa0aa 100644
--- a/system/slim/slim.SlackBuild
+++ b/system/slim/slim.SlackBuild
@@ -2,10 +2,12 @@
# Slackware build script for SLiM
-# Copyright 2006 Martin Lefebvre <dadexter@gmail.com>
-# Copyright 2007-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
+# Copyright 2006 Martin Lefebvre
+# Copyright 2007-2009 Frank Caraballo
# Copyright 2010,2013 Niels Horn, Rio de Janeiro, Brazil
-# Copyright 2014 Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
+# Copyright 2014 Ryan P.C. McQuen | Everett, WA
+# Formerly maintained by David Spencer
+# Copyright 2024 B. Watson <urchlay@slackware.uk>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,14 +26,17 @@
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Maintained by David Spencer <baildon.research@googlemail.com>
+
+# 20240924 bkw: BUILD=4
+# - take over maintenance.
+# - make /etc/slimlock.conf a .new config file.
+# - get useless INSTALL out of doc dir.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=slim
VERSION=${VERSION:-1.3.6}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-4}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -43,9 +48,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -78,11 +80,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
# Correct the path used for suspend and a few things about sessions
patch -p1 < $CWD/patches/slim-1.3.6-config.diff
@@ -98,7 +97,7 @@ patch -p1 < $CWD/patches/slim-1.3.6-gcc11.patch
patch -p1 < $CWD/patches/slim-1.3.6-envcpy-bad-pointer-arithmetic.patch
# Fix location of man-pages
-sed "s/share\/man/man/" -i CMakeLists.txt
+sed -i "s,share/man,man," CMakeLists.txt
mkdir -p build
cd build
@@ -111,7 +110,7 @@ cd build
-DUSE_CONSOLEKIT=no \
-DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
# Don't overwrite existing config file:
@@ -133,18 +132,15 @@ rm -rf $PKG/lib
install -m 0644 -D $CWD/files/Xsession $PKG/usr/share/slim/Xsession
install -m 0644 -D $CWD/files/slim.pam $PKG/etc/pam.d/slim/slim.pam
install -m 0644 -D $CWD/files/slimlock.pam $PKG/etc/pam.d/slimlock/slimlock.pam
-install -m 0644 -D slimlock.conf $PKG/etc/slimlock.conf
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+install -m 0644 -D slimlock.conf $PKG/etc/slimlock.conf.new
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man*/*
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog COPYING INSTALL README THEMES TODO xinitrc.sample $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a ChangeLog COPYING README THEMES TODO xinitrc.sample $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+cat $CWD/README.SLACKWARE > $PKGDOC/README.SLACKWARE
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/system/slim/slim.info b/system/slim/slim.info
index f4a2352728..76ef56e309 100644
--- a/system/slim/slim.info
+++ b/system/slim/slim.info
@@ -6,5 +6,5 @@ MD5SUM="d40d256394f9ef34cef34d2aa9cb52e6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="David Spencer"
-EMAIL="baildon.research@googlemail.com"
+MAINTAINER="B. Watson"
+EMAIL="urchlay@slackware.uk"