summaryrefslogtreecommitdiffstats
path: root/system/slmenu
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-01-11 13:05:49 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-01-17 09:03:29 +0700
commit8d93c32470175f84ef081ede5346d58ccc043950 (patch)
tree3be07d29c1ac31a63d89dda6e7d41a1a848f16da /system/slmenu
parent586754604ab1a355bb18b0dab674b53a5ed52e9d (diff)
downloadslackbuilds-8d93c32470175f84ef081ede5346d58ccc043950.tar.gz
slackbuilds-8d93c32470175f84ef081ede5346d58ccc043950.tar.xz
system/slmenu: Added (single line menu)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/slmenu')
-rw-r--r--system/slmenu/README4
-rw-r--r--system/slmenu/git2tarxz.sh44
-rw-r--r--system/slmenu/slack-desc19
-rw-r--r--system/slmenu/slmenu.SlackBuild77
-rw-r--r--system/slmenu/slmenu.info10
5 files changed, 154 insertions, 0 deletions
diff --git a/system/slmenu/README b/system/slmenu/README
new file mode 100644
index 0000000000..ace35977b4
--- /dev/null
+++ b/system/slmenu/README
@@ -0,0 +1,4 @@
+slmenu (single line menu)
+
+slmenu is a dmenu clone for the console. It works with the Linux
+console or any X or Wayland terminal emulator.
diff --git a/system/slmenu/git2tarxz.sh b/system/slmenu/git2tarxz.sh
new file mode 100644
index 0000000000..9717c7d813
--- /dev/null
+++ b/system/slmenu/git2tarxz.sh
@@ -0,0 +1,44 @@
+#!/bin/sh
+
+# Create source tarball from git repo, with generated version
+# number.
+
+# Note that this script doesn't need to be run as root. It does
+# need to be able to write to the current directory it's run from.
+
+# Takes one optional argument, which is the commit or tag to create
+# a tarball of. With no arg, HEAD is used.
+
+PRGNAM=slmenu
+CLONE_URL=https://github.com/joshaw/slmenu
+
+set -e
+
+GITDIR=$( mktemp -dt $PRGNAM.git.XXXXXX )
+rm -rf $GITDIR
+git clone $CLONE_URL $GITDIR
+
+CWD="$( pwd )"
+cd $GITDIR
+
+if [ "$1" != "" ]; then
+ git reset --hard "$1" || exit 1
+fi
+
+GIT_SHA=$( git rev-parse --short HEAD )
+
+DATE=$( git log --date=format:%Y%m%d --format=%cd | head -1 )
+
+VERSION=${DATE}_${GIT_SHA}
+
+rm -rf .git
+find . -name .gitignore -print0 | xargs -0 rm -f
+
+cd "$CWD"
+rm -rf $PRGNAM-$VERSION $PRGNAM-$VERSION.tar.xz
+mv $GITDIR $PRGNAM-$VERSION
+tar cvfJ $PRGNAM-$VERSION.tar.xz $PRGNAM-$VERSION
+
+echo
+echo "Created tarball: $PRGNAM-$VERSION.tar.xz"
+echo "VERSION=$VERSION"
diff --git a/system/slmenu/slack-desc b/system/slmenu/slack-desc
new file mode 100644
index 0000000000..380f1a2c19
--- /dev/null
+++ b/system/slmenu/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+slmenu: slmenu (single line menu)
+slmenu:
+slmenu: slmenu is a dmenu clone for the console. It works with the Linux
+slmenu: console or any X or Wayland terminal emulator.
+slmenu:
+slmenu:
+slmenu:
+slmenu:
+slmenu:
+slmenu:
+slmenu:
diff --git a/system/slmenu/slmenu.SlackBuild b/system/slmenu/slmenu.SlackBuild
new file mode 100644
index 0000000000..ee4cef839b
--- /dev/null
+++ b/system/slmenu/slmenu.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# Slackware build script for slmenu
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=slmenu
+VERSION=${VERSION:-20160415_b3740ca}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+sed -i "s,-Os,$SLKCFLAGS," config.mk
+sed -i '/@..CC/s,@,,' Makefile # show compile commands!
+
+make
+make install PREFIX=/usr MANPREFIX=/usr/man DESTDIR=$PKG
+
+gzip -9 $PKG/usr/man/man1/$PRGNAM.1
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* LICENSE* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/slmenu/slmenu.info b/system/slmenu/slmenu.info
new file mode 100644
index 0000000000..f918ef5ae4
--- /dev/null
+++ b/system/slmenu/slmenu.info
@@ -0,0 +1,10 @@
+PRGNAM="slmenu"
+VERSION="20160415_b3740ca"
+HOMEPAGE="https://github.com/joshaw/slmenu"
+DOWNLOAD="https://slackware.uk/~urchlay/src/slmenu-20160415_b3740ca.tar.xz"
+MD5SUM="720cc57bbde7e350f9e33549aa32e351"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"