summaryrefslogtreecommitdiffstats
path: root/system/pbzip2/Makefile.patch
diff options
context:
space:
mode:
author Erik Hanson <erik@slackbuilds.org>2010-05-11 15:18:42 +0200
committer Michiel van Wessem <michiel@slackbuilds.org>2010-05-11 15:18:42 +0200
commitf3a34d376ecea15be8eb56a386317d25f2e67249 (patch)
tree15134fd07700a02afa915aed62cda2011344d111 /system/pbzip2/Makefile.patch
parentcd62035bc1960706731969e45a0a7a776e1b5d97 (diff)
downloadslackbuilds-f3a34d376ecea15be8eb56a386317d25f2e67249.tar.gz
slackbuilds-f3a34d376ecea15be8eb56a386317d25f2e67249.tar.xz
system/pbzip2: Initial import
Diffstat (limited to 'system/pbzip2/Makefile.patch')
-rw-r--r--system/pbzip2/Makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/system/pbzip2/Makefile.patch b/system/pbzip2/Makefile.patch
new file mode 100644
index 0000000000..ef935dc8c1
--- /dev/null
+++ b/system/pbzip2/Makefile.patch
@@ -0,0 +1,22 @@
+--- Makefile 2007-03-14 15:59:20.000000000 -0500
++++ Makefile.new 2007-03-14 16:00:29.000000000 -0500
+@@ -11,16 +11,16 @@
+
+ # Standard pbzip2 compile
+ pbzip2: pbzip2.cpp
+- $(CC) -O3 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
++ $(CC) -O3 -march=i486 -mtune=i686 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
+
+ # Choose this if you want to compile in a static version of the libbz2 library
+ pbzip2-static: libbz2.a pbzip2.cpp
+- $(CC) -O3 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -I. -L. -lbz2
++ $(CC) -O3 -march=i486 -mtune=i686 -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o pbzip2 pbzip2.cpp -pthread -lpthread -I. -L. -lbz2
+
+ # Compatability mode for 32bit file sizes (less than 2GB) and systems
+ # that have compilers that treat int as 64bit natively (ie: modern AIX)
+ pbzip2-compat: pbzip2.cpp
+- $(CC) -O3 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
++ $(CC) -O3 -march=i486 -mtune=i686 -o pbzip2 pbzip2.cpp -pthread -lpthread -lbz2
+
+ # Install the binary pbzip2 program and man page
+ install: pbzip2