summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author isaackwy <isaacyu@protonmail.com>2024-03-08 19:47:35 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-03-10 21:48:44 +0700
commit486b437431e2f3319b8b2bbd5b904271f81a5f81 (patch)
tree8df939b99a5df1e78a4fb86ae696d8df12c1bfb8 /python
parent2c3879e85037dd406a7f183346ba1e9495f846eb (diff)
downloadslackbuilds-486b437431e2f3319b8b2bbd5b904271f81a5f81.tar.gz
slackbuilds-486b437431e2f3319b8b2bbd5b904271f81a5f81.tar.xz
python/python3-pydocstyle: Update for 6.3.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-pydocstyle/python3-pydocstyle.SlackBuild11
-rw-r--r--python/python3-pydocstyle/python3-pydocstyle.info6
2 files changed, 12 insertions, 5 deletions
diff --git a/python/python3-pydocstyle/python3-pydocstyle.SlackBuild b/python/python3-pydocstyle/python3-pydocstyle.SlackBuild
index 8f43b4b881..b7b4d9ae34 100644
--- a/python/python3-pydocstyle/python3-pydocstyle.SlackBuild
+++ b/python/python3-pydocstyle/python3-pydocstyle.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pydocstyle
-VERSION=${VERSION:-6.2.0}
+VERSION=${VERSION:-6.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,7 +66,14 @@ find -L . \
# Fix version number within metadata (code taken from the Arch Linux PKGBUILD):
# https://gitlab.archlinux.org/archlinux/packaging/packages/python-pydocstyle/-/blob/main/PKGBUILD
-sed -e "s|^version = .*|version = \"$VERSION\"|" -i pyproject.toml
+sed -e "s|version = \"0.0.0-dev\"|version = \"$VERSION\"|" -i pyproject.toml
+
+# The source (optionally) requires tomli at >=1.2.3 for reading .toml configs.
+# However, the only change between tomli 1.2.2 and 1.2.3 is a fix that allows lower case "t" and "z" within datetimes:
+# https://github.com/hukkin/tomli/compare/1.2.2...1.2.3
+# These edits allow python3-pydocstyle to use tomli 1.2.2 (the version installed in Slackware 15.0) instead.
+sed -e "s|version = \">=1.2.3\"|version = \">=1.2.2\"|" -i pyproject.toml
+sed "s/tomli>=1.2.3/tomli>=1.2.2/g" -i requirements/runtime.txt
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl
diff --git a/python/python3-pydocstyle/python3-pydocstyle.info b/python/python3-pydocstyle/python3-pydocstyle.info
index 0ee2aa1a7e..1bd7fbc035 100644
--- a/python/python3-pydocstyle/python3-pydocstyle.info
+++ b/python/python3-pydocstyle/python3-pydocstyle.info
@@ -1,8 +1,8 @@
PRGNAM="python3-pydocstyle"
-VERSION="6.2.0"
+VERSION="6.3.0"
HOMEPAGE="http://www.pydocstyle.org/"
-DOWNLOAD="https://github.com/PyCQA/pydocstyle/archive/6.2.0/pydocstyle-6.2.0.tar.gz"
-MD5SUM="aa1ed3b326ffed8f4e857aa0f79bfa44"
+DOWNLOAD="https://github.com/PyCQA/pydocstyle/archive/6.3.0/pydocstyle-6.3.0.tar.gz"
+MD5SUM="2327b2a8d30cc1f293339b9c1ee53956"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-poetry-core snowballstemmer"