summaryrefslogtreecommitdiffstats
path: root/python/xlutils/xlutils.SlackBuild
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-05-15 22:22:38 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:40 +0700
commit4a116d29cc439427ef7f48c191737e46f972a6fc (patch)
tree16e563273108fde520dc7c10c81cbdfbab37a88a /python/xlutils/xlutils.SlackBuild
parent8b0d57fb71a5d0f050d2fb26727d764124b2d33d (diff)
downloadslackbuilds-4a116d29cc439427ef7f48c191737e46f972a6fc.tar.gz
slackbuilds-4a116d29cc439427ef7f48c191737e46f972a6fc.tar.xz
python/xlutils: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/xlutils/xlutils.SlackBuild')
-rw-r--r--python/xlutils/xlutils.SlackBuild21
1 files changed, 7 insertions, 14 deletions
diff --git a/python/xlutils/xlutils.SlackBuild b/python/xlutils/xlutils.SlackBuild
index cab70ba611..bb347a45a5 100644
--- a/python/xlutils/xlutils.SlackBuild
+++ b/python/xlutils/xlutils.SlackBuild
@@ -42,15 +42,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -65,18 +62,14 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
- # Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
-fi
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+# Python 2.7 will be droped in the future.
+python2 setup.py install --root=$PKG
+
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION