summaryrefslogtreecommitdiffstats
path: root/python/xe
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-03-30 15:07:04 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-02 18:18:45 +0700
commit2d9e7b456111d007effb6045def130d7ac9dd008 (patch)
tree7662292119cbd13186bf49df0869d742cf0b7b35 /python/xe
parent5f79b7cafb3588d9847353e5ba9f84b67bd7c46e (diff)
downloadslackbuilds-2d9e7b456111d007effb6045def130d7ac9dd008.tar.gz
slackbuilds-2d9e7b456111d007effb6045def130d7ac9dd008.tar.xz
python/xe: Fix download URL.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/xe')
-rw-r--r--python/xe/xe.SlackBuild17
-rw-r--r--python/xe/xe.info2
2 files changed, 9 insertions, 10 deletions
diff --git a/python/xe/xe.SlackBuild b/python/xe/xe.SlackBuild
index 964c98f110..23bbc3f12b 100644
--- a/python/xe/xe.SlackBuild
+++ b/python/xe/xe.SlackBuild
@@ -14,15 +14,12 @@ PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -32,8 +29,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -52,14 +49,16 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+[ -e $CWD/$PRGNAM-$VERSION.tar.gz ] && \
+ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || \
+ tar xvf $CWD/xmlelements_$VERSION.orig.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
python setup.py install --root=$PKG
diff --git a/python/xe/xe.info b/python/xe/xe.info
index f199f304a5..2dae46be8e 100644
--- a/python/xe/xe.info
+++ b/python/xe/xe.info
@@ -1,7 +1,7 @@
PRGNAM="xe"
VERSION="0.7.4"
HOMEPAGE="http://home.avvanta.com/~steveha/xe.html"
-DOWNLOAD="http://www.blarg.net/~steveha/xe-0.7.4.tar.gz"
+DOWNLOAD="http://archive.ubuntu.com/ubuntu/pool/universe/x/xmlelements/xmlelements_0.7.4.orig.tar.gz"
MD5SUM="eff507b7a3700c93bd5ba756d4a6f457"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""