summaryrefslogtreecommitdiffstats
path: root/python/python3-Flask-SQLAlchemy
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-09-17 19:11:44 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-23 11:33:51 +0700
commit6ab2b542f37f50f977e13ad6deae25b9a098b01a (patch)
tree9a42e30757b0404585d973fb0be9545d83e18fc2 /python/python3-Flask-SQLAlchemy
parentaa8b81e601df4d5c2eb8b894a0d8cec087129fff (diff)
downloadslackbuilds-6ab2b542f37f50f977e13ad6deae25b9a098b01a.tar.gz
slackbuilds-6ab2b542f37f50f977e13ad6deae25b9a098b01a.tar.xz
python/python3-Flask-SQLAlchemy: Updated for version 3.0.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-Flask-SQLAlchemy')
-rw-r--r--python/python3-Flask-SQLAlchemy/README3
-rw-r--r--python/python3-Flask-SQLAlchemy/python3-Flask-SQLAlchemy.SlackBuild22
-rw-r--r--python/python3-Flask-SQLAlchemy/python3-Flask-SQLAlchemy.info8
3 files changed, 19 insertions, 14 deletions
diff --git a/python/python3-Flask-SQLAlchemy/README b/python/python3-Flask-SQLAlchemy/README
index ed59eeb0d7..683a6368ce 100644
--- a/python/python3-Flask-SQLAlchemy/README
+++ b/python/python3-Flask-SQLAlchemy/README
@@ -1,2 +1,5 @@
python3-Flask-SQLAlchemy is a Flask microframework extension which
adds support for the SQLAlchemy SQL toolkit/ORM.
+
+NOTE: 3.0.x is last version that supports SQLAlchemy 1.4.x.
+ 3.1.x or greater requires SQLAlchemy >=2.16.0
diff --git a/python/python3-Flask-SQLAlchemy/python3-Flask-SQLAlchemy.SlackBuild b/python/python3-Flask-SQLAlchemy/python3-Flask-SQLAlchemy.SlackBuild
index 92ff0e26b0..0708db769e 100644
--- a/python/python3-Flask-SQLAlchemy/python3-Flask-SQLAlchemy.SlackBuild
+++ b/python/python3-Flask-SQLAlchemy/python3-Flask-SQLAlchemy.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-Flask-SQLAlchemy
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230917 46and2: Updated version, build process changed.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-Flask-SQLAlchemy
-SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-2.5.1}
+SRCNAM=flask_sqlalchemy
+VERSION=${VERSION:-3.0.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -60,6 +59,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -76,12 +78,12 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-Flask-SQLAlchemy/python3-Flask-SQLAlchemy.info b/python/python3-Flask-SQLAlchemy/python3-Flask-SQLAlchemy.info
index 36a316eebe..99514ef34f 100644
--- a/python/python3-Flask-SQLAlchemy/python3-Flask-SQLAlchemy.info
+++ b/python/python3-Flask-SQLAlchemy/python3-Flask-SQLAlchemy.info
@@ -1,10 +1,10 @@
PRGNAM="python3-Flask-SQLAlchemy"
-VERSION="2.5.1"
+VERSION="3.0.5"
HOMEPAGE="https://github.com/mitsuhiko/flask-sqlalchemy"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-sqlalchemy/Flask-SQLAlchemy-2.5.1.tar.gz"
-MD5SUM="dcb6b62248ced71dab183f2cb2778583"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-sqlalchemy/flask_sqlalchemy-3.0.5.tar.gz"
+MD5SUM="d7273df5991bcd9510afe52a1cb07bfc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="Flask SQLAlchemy"
+REQUIRES="python3-build Flask SQLAlchemy"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"