summaryrefslogtreecommitdiffstats
path: root/python/python-uri-templates
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-14 21:34:46 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:04 +0700
commitf994f105c6a511d82e6bdfb0c127444e7f9f74c4 (patch)
tree6d7f5cf51b92ec92dc83f7e08c5ca77de630722f /python/python-uri-templates
parent876dae8127f136b9d31d4e926e4ec6786e59e2f1 (diff)
downloadslackbuilds-f994f105c6a511d82e6bdfb0c127444e7f9f74c4.tar.gz
slackbuilds-f994f105c6a511d82e6bdfb0c127444e7f9f74c4.tar.xz
python/python-uri-templates: Renamed python2-uri-templates.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-uri-templates')
-rw-r--r--python/python-uri-templates/README2
-rw-r--r--python/python-uri-templates/python-uri-templates.SlackBuild88
-rw-r--r--python/python-uri-templates/python-uri-templates.info10
-rw-r--r--python/python-uri-templates/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/python/python-uri-templates/README b/python/python-uri-templates/README
deleted file mode 100644
index 30973b3c00..0000000000
--- a/python/python-uri-templates/README
+++ /dev/null
@@ -1,2 +0,0 @@
-Youtube-upload is a command line Python script that uploads videos
-to Youtube using the YouTube APIv3.
diff --git a/python/python-uri-templates/python-uri-templates.SlackBuild b/python/python-uri-templates/python-uri-templates.SlackBuild
deleted file mode 100644
index 7e31c4edb6..0000000000
--- a/python/python-uri-templates/python-uri-templates.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for "python-uri-templates".
-
-# Copyright 2015 Marcel Saegebarth <marc@mos6581.de>
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
-#
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-uri-templates
-SRCNAM1=uri-template-py
-SRCNAM2=uritemplate-py-uri-template-py
-VERSION=${VERSION:-0.6}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM2-$VERSION
-tar xvf $CWD/$SRCNAM1-$VERSION.tar.gz || tar xvf $CWD/$SRCNAM2-$VERSION.tar.gz
-cd $SRCNAM2-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root $PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- MAINTAINERS.rst README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-uri-templates/python-uri-templates.info b/python/python-uri-templates/python-uri-templates.info
deleted file mode 100644
index 3fdd2a3ec3..0000000000
--- a/python/python-uri-templates/python-uri-templates.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-uri-templates"
-VERSION="0.6"
-HOMEPAGE="https://github.com/uri-templates/"
-DOWNLOAD="https://github.com/uri-templates/uritemplate-py/archive/uri-template-py-0.6.tar.gz"
-MD5SUM="e15925c2fceb09150011618e31e250ac"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="simplejson"
-MAINTAINER="Marcel Saegebarth"
-EMAIL="marc@mos6581.de"
diff --git a/python/python-uri-templates/slack-desc b/python/python-uri-templates/slack-desc
deleted file mode 100644
index eb5690706f..0000000000
--- a/python/python-uri-templates/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-uri-templates: python-uri-templates (Python implementation of URI Template)
-python-uri-templates:
-python-uri-templates: This is a Python implementation of RFC6570, URI Template, and can
-python-uri-templates: expand templates up to and including Level 4 in that specification.
-python-uri-templates:
-python-uri-templates: Homepage: https://github.com/uri-templates/
-python-uri-templates:
-python-uri-templates:
-python-uri-templates:
-python-uri-templates:
-python-uri-templates: