summaryrefslogtreecommitdiffstats
path: root/python/python-lz4
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-14 23:57:21 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:04 +0700
commitd889bca7a9109e743fdc95e752455a878f53a4a5 (patch)
tree0ae8e218d34f12de6a08d1da690c34a691dfd97d /python/python-lz4
parent9ee78a09f8821eb25e80efa76bb0e25d7fc67666 (diff)
downloadslackbuilds-d889bca7a9109e743fdc95e752455a878f53a4a5.tar.gz
slackbuilds-d889bca7a9109e743fdc95e752455a878f53a4a5.tar.xz
python/python-lz4: Renamed python2-lz4.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-lz4')
-rw-r--r--python/python-lz4/README12
-rw-r--r--python/python-lz4/python-lz4.SlackBuild88
-rw-r--r--python/python-lz4/python-lz4.info10
-rw-r--r--python/python-lz4/slack-desc19
4 files changed, 0 insertions, 129 deletions
diff --git a/python/python-lz4/README b/python/python-lz4/README
deleted file mode 100644
index b3ddbb25ae..0000000000
--- a/python/python-lz4/README
+++ /dev/null
@@ -1,12 +0,0 @@
-python-lz4: provides python bindings for the LZ4 compression library.
-
-The bindings provided in this package cover the frame format and the block
-format specifications. The frame format bindings are the recommended ones to
-use, as this guarantees interoperability with other implementations and
-language bindings.
-
-The API provided by the frame format bindings follows that of the LZMA, zlib,
-gzip and bzip2 compression libraries which are provided with the Python
-standard library. As such, these LZ4 bindings should provide a drop-in
-alternative to the compression libraries shipped with Python. The package
-provides context managers and file handler support.
diff --git a/python/python-lz4/python-lz4.SlackBuild b/python/python-lz4/python-lz4.SlackBuild
deleted file mode 100644
index 17c1dc269e..0000000000
--- a/python/python-lz4/python-lz4.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-lz4
-
-# Copyright 2019, Barry J. Grundy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# New Submission, version 2.1.6 Jan 2019
-
-PRGNAM=python-lz4
-TARNAM=lz4
-VERSION=${VERSION:-2.1.6}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$TARNAM-$VERSION.tar.gz
-cd $TARNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.rst docs/ $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-lz4/python-lz4.info b/python/python-lz4/python-lz4.info
deleted file mode 100644
index ee56ac9c40..0000000000
--- a/python/python-lz4/python-lz4.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-lz4"
-VERSION="2.1.6"
-HOMEPAGE="https://github.com/python-lz4/python-lz4"
-DOWNLOAD="https://files.pythonhosted.org/packages/b3/48/ef32029fc6ae23fb37568972216646deeaaf9f833c237afdf37c0d975bff/lz4-2.1.6.tar.gz"
-MD5SUM="badde942dabaac89256243b87977c49c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="setuptools-scm"
-MAINTAINER="Barry J. Grundy"
-EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/python-lz4/slack-desc b/python/python-lz4/slack-desc
deleted file mode 100644
index c9c73e5fa0..0000000000
--- a/python/python-lz4/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-lz4: python-lz4 (python bindings for lz4 compression library)
-python-lz4:
-python-lz4: These lz4 bindings provide a drop-in alternative to the
-python-lz4: compression libraries shipped with Python.
-python-lz4:
-python-lz4:
-python-lz4:
-python-lz4:
-python-lz4:
-python-lz4:
-python-lz4: