summaryrefslogtreecommitdiffstats
path: root/python/python-evdev/python-evdev.SlackBuild
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2022-03-24 00:19:36 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-02 18:18:53 +0700
commitc53084a35a9966f44a083646ab970d7b19cc3ace (patch)
tree041b7e36d4c2e675b9f3b3d451848d342b775400 /python/python-evdev/python-evdev.SlackBuild
parent7d137939a13e81dd31bb234e7dadc964eaef07b7 (diff)
downloadslackbuilds-c53084a35a9966f44a083646ab970d7b19cc3ace.tar.gz
slackbuilds-c53084a35a9966f44a083646ab970d7b19cc3ace.tar.xz
python/python-evdev: Update for 1.5.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-evdev/python-evdev.SlackBuild')
-rw-r--r--python/python-evdev/python-evdev.SlackBuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/python/python-evdev/python-evdev.SlackBuild b/python/python-evdev/python-evdev.SlackBuild
index 79cd6294f3..89699b5ac3 100644
--- a/python/python-evdev/python-evdev.SlackBuild
+++ b/python/python-evdev/python-evdev.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python-evdev
# Copyright 2015 Dugan Chen, Canada <thedoogster@gmail.com>
-# Copyright 2020-2021 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-evdev
-VERSION=${VERSION:-1.4.0}
+VERSION=${VERSION:-1.5.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -86,10 +86,7 @@ find -L . \
find -L . -perm 660 -exec chmod 644 {} \;
python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true