summaryrefslogtreecommitdiffstats
path: root/python/pytables/pytables.SlackBuild
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2011-12-14 23:16:13 -0600
committer Niels Horn <niels.horn@slackbuilds.org>2011-12-18 00:07:51 -0200
commite4b69a1300cfb9ced3ffd49c4cfd78120a89563a (patch)
treed3e43307b64b9851a27a8d26d5a81b97f7be7ae3 /python/pytables/pytables.SlackBuild
parent3e0d30e099ebdbc5fde8599bf652fb649eedad74 (diff)
downloadslackbuilds-e4b69a1300cfb9ced3ffd49c4cfd78120a89563a.tar.gz
slackbuilds-e4b69a1300cfb9ced3ffd49c4cfd78120a89563a.tar.xz
python/pytables: Updated for version 2.3.1.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/pytables/pytables.SlackBuild')
-rw-r--r--python/pytables/pytables.SlackBuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/python/pytables/pytables.SlackBuild b/python/pytables/pytables.SlackBuild
index fb5822657f..9e052783cb 100644
--- a/python/pytables/pytables.SlackBuild
+++ b/python/pytables/pytables.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pytables
-VERSION=${VERSION:-2.2.1}
+VERSION=${VERSION:-2.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -42,8 +42,7 @@ OUTPUT=${OUTPUT:-/tmp}
SRC_PRGNAM=tables
DOCFILES="RELEASE_NOTES.txt LICENSES/ MIGRATING_TO_2.x.txt THANKS \
- ANNOUNCE.txt LICENSE.txt PKG-INFO README.txt doc/html doc/scripts \
- doc/text doc/usersguide.pdf"
+ ANNOUNCE.txt LICENSE.txt PKG-INFO README.txt doc/html doc/scripts"
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
@@ -74,7 +73,7 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" python setup.py build install --prefix=/usr --root=$PKG
+python setup.py build install --prefix=/usr --root=$PKG
# Copy examples, contrib, and bench files
mkdir -p $PKG/usr/share/$PRGNAM/
@@ -86,7 +85,7 @@ cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
cp $CWD/pytablesmanual-$VERSION.pdf $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/install