summaryrefslogtreecommitdiffstats
path: root/python/pygame/pygame.SlackBuild
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2022-02-20 23:01:28 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-21 14:30:42 +0700
commitb3e7e57e3159a683daf11be981002cfd0bcddb99 (patch)
treeecb5f23fd160fe94bc29b634d148c287673c5a84 /python/pygame/pygame.SlackBuild
parentaaccdb9428cfe38a19363bb97f317c6a97d096ce (diff)
downloadslackbuilds-b3e7e57e3159a683daf11be981002cfd0bcddb99.tar.gz
slackbuilds-b3e7e57e3159a683daf11be981002cfd0bcddb99.tar.xz
python/pygame: Updated for version 2.0.3.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pygame/pygame.SlackBuild')
-rw-r--r--python/pygame/pygame.SlackBuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
index 3792d996f3..90134bec34 100644
--- a/python/pygame/pygame.SlackBuild
+++ b/python/pygame/pygame.SlackBuild
@@ -6,7 +6,7 @@
# Modified by the SlackBuilds.org project
# Maintained by Bojan Popovic (bocke@slackware-srbija.org), 2014-2017
# Contribution by B.Watson (yalhcru@gmail.com), 11 apr. 2017.
-# Copyright 2017-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2017-2022 Dimitris Zlatanidis Orestiada, Greece
#
# All rights reserved.
#
@@ -30,7 +30,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pygame
-VERSION=${VERSION:-2.0.2}
+VERSION=${VERSION:-2.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,11 +80,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/setup.patch
+
+# Since portmidi 2.0.2, libporttime is included in libportmidi.
+# Therfore use config-settings like for Fedora.
+sed -i 's;/etc/redhat-release;/etc/slackware-version;' buildconfig/config_unix.py
+
# Contributed by B.Watson (yalhcru@gmail.com).
# Gets rid of the call to remove_old_files() during packaging.
# TLDR: Stops packaging scripts from messing with a local PyGame install.
sed -i '/^if "install"/,$d' setup.py
+# Pygame version 2.0.3 is the last that supports python2
python2 -u buildconfig/config.py
CFLAGS="$SLKCFLAGS" \
python2 setup.py install --root=$PKG
@@ -96,7 +103,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst docs/LGPL.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst docs/LGPL.txt docs/README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install