summaryrefslogtreecommitdiffstats
path: root/python/pip/pip.SlackBuild
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2013-07-28 11:23:38 -0500
committer Erik Hanson <erik@slackbuilds.org>2013-10-12 14:38:02 -0500
commitdff549c070950e1e2fafc2664448cfab42a44561 (patch)
treedc3dfdee2f5bd220ad66673184c72d9a27a64dff /python/pip/pip.SlackBuild
parent9c25ab7047cb225af86bcf1f9f80d66a58df642f (diff)
downloadslackbuilds-dff549c070950e1e2fafc2664448cfab42a44561.tar.gz
slackbuilds-dff549c070950e1e2fafc2664448cfab42a44561.tar.xz
python/pip: Updated for version 1.4.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'python/pip/pip.SlackBuild')
-rw-r--r--python/pip/pip.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/python/pip/pip.SlackBuild b/python/pip/pip.SlackBuild
index 3c201a2630..be450bd618 100644
--- a/python/pip/pip.SlackBuild
+++ b/python/pip/pip.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pip
-VERSION=${VERSION:-1.3.1}
+VERSION=${VERSION:-1.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,6 +57,11 @@ find . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
# Add bash completion file.
install -D -m 644 $CWD/pip.sh $PKG/usr/share/bash-completion/completions/pip