summaryrefslogtreecommitdiffstats
path: root/python/colorclass
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2024-05-12 19:56:06 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-18 06:55:35 +0700
commite47a1c138c680e8fdac97cde2de6acfd5b22903e (patch)
tree0a55a6c06c9d5fd552cd17094d5455326e719644 /python/colorclass
parent8f30d54ec09e1964cd289e532bd6a1a1800c49b4 (diff)
downloadslackbuilds-e47a1c138c680e8fdac97cde2de6acfd5b22903e.tar.gz
slackbuilds-e47a1c138c680e8fdac97cde2de6acfd5b22903e.tar.xz
python/colorclass: Removed unused.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/colorclass')
-rw-r--r--python/colorclass/README3
-rw-r--r--python/colorclass/colorclass.SlackBuild95
-rw-r--r--python/colorclass/colorclass.info10
-rw-r--r--python/colorclass/slack-desc19
4 files changed, 0 insertions, 127 deletions
diff --git a/python/colorclass/README b/python/colorclass/README
deleted file mode 100644
index 8d844e6b48..0000000000
--- a/python/colorclass/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Yet another ANSI color text library for Python.
-Provides "auto colors" for dark/light terminals.
-Works on Linux, OS X, and Windows.
diff --git a/python/colorclass/colorclass.SlackBuild b/python/colorclass/colorclass.SlackBuild
deleted file mode 100644
index c3913fd04c..0000000000
--- a/python/colorclass/colorclass.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for colorclass
-
-# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=colorclass
-VERSION=${VERSION:-2.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/colorclass/colorclass.info b/python/colorclass/colorclass.info
deleted file mode 100644
index ab09e62cb1..0000000000
--- a/python/colorclass/colorclass.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="colorclass"
-VERSION="2.2.0"
-HOMEPAGE="https://github.com/Robpol86/colorclass"
-DOWNLOAD="https://pypi.python.org/packages/37/ea/ae8dbb956939d4392e6a7fdef87fda273854da1128edae016c4104240be8/colorclass-2.2.0.tar.gz"
-MD5SUM="060139e93e31faafeb5d4bdfd6ea0bb8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/colorclass/slack-desc b/python/colorclass/slack-desc
deleted file mode 100644
index 23d70acd74..0000000000
--- a/python/colorclass/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-colorclass: colorclass (ANSI color text library for Python)
-colorclass:
-colorclass: Yet another ANSI color text library for Python. Provides
-colorclass: `auto colors` for dark/light terminals. Works on Linux, OS X, and
-colorclass: Windows.
-colorclass:
-colorclass: Homepage: https://github.com/Robpol86/colorclass
-colorclass:
-colorclass:
-colorclass:
-colorclass: