summaryrefslogtreecommitdiffstats
path: root/python/Beaker
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-21 21:32:05 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-06-02 01:02:21 +0700
commit633150fbbd18773852d2552c9065eb1d12a69b91 (patch)
treee0a803c342a19b85a06ba86b99f3ccaf5dee354b /python/Beaker
parent95a4deb7b47a9a4e62028d66865bf86c98ed23f9 (diff)
downloadslackbuilds-633150fbbd18773852d2552c9065eb1d12a69b91.tar.gz
slackbuilds-633150fbbd18773852d2552c9065eb1d12a69b91.tar.xz
python/Beaker: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/Beaker')
-rw-r--r--python/Beaker/Beaker.SlackBuild6
-rw-r--r--python/Beaker/README9
2 files changed, 7 insertions, 8 deletions
diff --git a/python/Beaker/Beaker.SlackBuild b/python/Beaker/Beaker.SlackBuild
index 1c07ef22dc..6efce1a551 100644
--- a/python/Beaker/Beaker.SlackBuild
+++ b/python/Beaker/Beaker.SlackBuild
@@ -53,10 +53,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a README* $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/Beaker/README b/python/Beaker/README
index f555fa542b..430003fca1 100644
--- a/python/Beaker/README
+++ b/python/Beaker/README
@@ -1,5 +1,6 @@
-Beaker is a library for caching and sessions for use with web applications and
-stand-alone Python scripts and applications.
+Beaker is a library for caching and sessions for use with web
+applications and stand-alone Python scripts and applications.
+
It comes with WSGI middleware for easy drop-in use with WSGI based web
-applications, and caching decorators for ease of use with any Python based
-application.
+applications, and caching decorators for ease of use with any Python
+based application.