summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2010-05-18 00:53:33 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-05-19 09:06:58 -0500
commitfac28ae4f210a919fda84f7305b834aa5d1b4b07 (patch)
tree484d9f43d71b0d8bcb1c02879b4dda65c5615447 /libraries
parenta5da8806b2b722621a045175586fe415b1b7166f (diff)
downloadslackbuilds-fac28ae4f210a919fda84f7305b834aa5d1b4b07.tar.gz
slackbuilds-fac28ae4f210a919fda84f7305b834aa5d1b4b07.tar.xz
libraries/loudmouth: Removed (part of Slackware 13.1)
Diffstat (limited to 'libraries')
-rw-r--r--libraries/loudmouth/README4
-rw-r--r--libraries/loudmouth/loudmouth-1.4.3-gnutls28.patch15
-rw-r--r--libraries/loudmouth/loudmouth.SlackBuild91
-rw-r--r--libraries/loudmouth/loudmouth.info10
-rw-r--r--libraries/loudmouth/slack-desc19
5 files changed, 0 insertions, 139 deletions
diff --git a/libraries/loudmouth/README b/libraries/loudmouth/README
deleted file mode 100644
index 08d46de13b..0000000000
--- a/libraries/loudmouth/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Loudmouth is a lightweight and easy-to-use C library for programming
-with the Jabber protocol. It's designed to be easy to get started
-with and yet extensible to let you do anything the Jabber protocol
-allows. \ No newline at end of file
diff --git a/libraries/loudmouth/loudmouth-1.4.3-gnutls28.patch b/libraries/loudmouth/loudmouth-1.4.3-gnutls28.patch
deleted file mode 100644
index a538533db0..0000000000
--- a/libraries/loudmouth/loudmouth-1.4.3-gnutls28.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-# Gentoo: https://bugs.gentoo.org/show_bug.cgi?id=272027
-# Patch from mandriva
---- a/configure.ac 2009-05-30 17:59:03.000000000 +0200
-+++ b/configure.ac 2009-05-30 18:02:24.000000000 +0200
-@@ -146,8 +146,9 @@
- enable_ssl=no
- if test "x$ac_ssl" = "xgnutls"; then
- dnl Look for GnuTLS
-- AM_PATH_LM_LIBGNUTLS($GNUTLS_REQUIRED, have_libgnutls=yes, have_libgnutls=no)
-+ PKG_CHECK_EXISTS([gnutls >= $GNUTLS_REQUIRED], have_libgnutls=yes, have_libgnutls=no)
- if test "x$have_libgnutls" = "xyes"; then
-+ PKG_CHECK_MODULES(LIBGNUTLS, [gnutls >= $GNUTLS_REQUIRED])
- CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
- LIBS="$LIBS $LIBGNUTLS_LIBS"
- AC_DEFINE(HAVE_GNUTLS, 1, [whether to use GnuTSL support.])
diff --git a/libraries/loudmouth/loudmouth.SlackBuild b/libraries/loudmouth/loudmouth.SlackBuild
deleted file mode 100644
index d30247301b..0000000000
--- a/libraries/loudmouth/loudmouth.SlackBuild
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for loudmouth
-
-# Copyright 2008-2009 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=loudmouth
-VERSION=1.4.3
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-#fix finding gnutls-2.8
-patch -p1 -i $CWD/loudmouth-1.4.3-gnutls28.patch
-
-autoreconf -vif
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-static \
- --with-html-dir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux \
- --host=$ARCH-slackware-linux
-
-make
-make install-strip DESTDIR=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog CONTRIBUTORS COPYING INSTALL NEWS README* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/loudmouth/loudmouth.info b/libraries/loudmouth/loudmouth.info
deleted file mode 100644
index 660c575656..0000000000
--- a/libraries/loudmouth/loudmouth.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="loudmouth"
-VERSION="1.4.3"
-HOMEPAGE="http://www.loudmouth-project.org/"
-DOWNLOAD="http://ftp.gnome.org/pub/GNOME/sources/loudmouth/1.4/loudmouth-1.4.3.tar.bz2"
-MD5SUM="55339ca42494690c3942ee1465a96937"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@liwjatan.at"
-APPROVED="dsomero"
diff --git a/libraries/loudmouth/slack-desc b/libraries/loudmouth/slack-desc
deleted file mode 100644
index d61171fc30..0000000000
--- a/libraries/loudmouth/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler----------------------------------------------------|
-loudmouth: loudmouth (Jabber Protocol library)
-loudmouth:
-loudmouth: Loudmouth is a lightweight and easy-to-use C library for programming
-loudmouth: with the Jabber protocol. It's designed to be easy to get started
-loudmouth: with and yet extensible to let you do anything the Jabber protocol
-loudmouth: allows.
-loudmouth:
-loudmouth: Homepage: http://www.loudmouth-project.org/
-loudmouth:
-loudmouth:
-loudmouth: