summaryrefslogtreecommitdiffstats
path: root/libraries/poco/poco_mariadb.patch
diff options
context:
space:
mode:
author Edward W. Koenig <kingbeowulf@linuxgalaxy.org>2022-12-29 11:50:04 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-31 09:14:46 +0700
commit141fc676bc50a3f33131a0fcee895062776579ba (patch)
tree30204ab18e77fea1e51cc4d394bcb52692252074 /libraries/poco/poco_mariadb.patch
parente00824a64f70d1d1486f9c896207613df22120dd (diff)
downloadslackbuilds-141fc676bc50a3f33131a0fcee895062776579ba.tar.gz
slackbuilds-141fc676bc50a3f33131a0fcee895062776579ba.tar.xz
libraries/poco: New maintainer, script improvements
Signed-off-by: Edward W. Koenig <kingbeowulf@linuxgalaxy.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to '')
-rw-r--r--libraries/poco/poco_mariadb.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/libraries/poco/poco_mariadb.patch b/libraries/poco/poco_mariadb.patch
new file mode 100644
index 0000000000..c8a82ec79e
--- /dev/null
+++ b/libraries/poco/poco_mariadb.patch
@@ -0,0 +1,12 @@
+diff -uNr poco/Data/MySQL/CMakeLists.txt poco_changed/Data/MySQL/CMakeLists.txt
+--- poco/Data/MySQL/CMakeLists.txt 2021-06-28 12:16:01.000000000 +0200
++++ poco_changed/Data/MySQL/CMakeLists.txt 2021-10-14 14:53:52.605311071 +0200
+@@ -21,7 +21,7 @@
+ DEFINE_SYMBOL MySQL_EXPORTS
+ )
+
+-target_link_libraries(DataMySQL PUBLIC Poco::Data MySQL::client)
++target_link_libraries(DataMySQL PUBLIC Poco::Data mariadb)
+ target_include_directories(DataMySQL
+ PUBLIC
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>