summaryrefslogtreecommitdiffstats
path: root/libraries/libquicktime/libquicktime-1.2.4-faad2.patch
diff options
context:
space:
mode:
author Heinz Wiesinger <pprkut@slackbuilds.org>2021-09-18 18:12:21 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-09-22 11:33:21 +0700
commit39c8cc2e84fa32723517bc97fe01b0e63b9fc45a (patch)
tree7b072c0178b50280448bed0bc8ac3848d9513148 /libraries/libquicktime/libquicktime-1.2.4-faad2.patch
parent9c3b29e005039266d2d765eeb86352d23ea3be29 (diff)
downloadslackbuilds-39c8cc2e84fa32723517bc97fe01b0e63b9fc45a.tar.gz
slackbuilds-39c8cc2e84fa32723517bc97fe01b0e63b9fc45a.tar.xz
libraries/libquicktime: Don't install *.la files
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/libquicktime/libquicktime-1.2.4-faad2.patch')
-rw-r--r--libraries/libquicktime/libquicktime-1.2.4-faad2.patch86
1 files changed, 86 insertions, 0 deletions
diff --git a/libraries/libquicktime/libquicktime-1.2.4-faad2.patch b/libraries/libquicktime/libquicktime-1.2.4-faad2.patch
new file mode 100644
index 0000000000..563f46426f
--- /dev/null
+++ b/libraries/libquicktime/libquicktime-1.2.4-faad2.patch
@@ -0,0 +1,86 @@
+diff -ruN a/configure.ac b/configure.ac
+--- a/configure.ac 2012-03-29 21:44:28.000000000 +0200
++++ b/configure.ac 2020-02-09 18:27:31.599127781 +0100
+@@ -728,82 +728,9 @@
+
+ if test "x$with_faad2" != "xno"; then
+
+-OLD_CFLAGS=$CFLAGS
+-OLD_LIBS=$LIBS
+-
+ CFLAGS="$CFLAGS"
+ LIBS="$LIBS -lfaad -lm"
+
+-AC_MSG_CHECKING(for neaacdec.h usability for faad2)
+-
+-
+-AC_TRY_RUN([
+- #include <neaacdec.h>
+- #include <stdio.h>
+- main()
+- {
+- int faad_major;
+- int faad_minor;
+- faacDecHandle dec;
+-
+- if(sscanf(FAAD2_VERSION, "%d.%d", &faad_major, &faad_minor) < 2)
+- return -1;
+- dec = faacDecOpen();
+- if(!dec)
+- return -1;
+- return 0;
+- }
+- ],
+- [
+- # program could be run
+- have_faad2="true"
+- AC_MSG_RESULT(yes)
+- FAAD2_CFLAGS=$CFLAGS
+- FAAD2_LIBS=$LIBS
+- AC_DEFINE(HAVE_NEAACDEC_H)
+- ],
+- # program could not be run
+- AC_MSG_RESULT(no)
+-)
+-
+-if test "x$have_faad2" != "xtrue"; then
+-
+-AC_MSG_CHECKING(for faad.h usability for faad2)
+-
+-AC_TRY_RUN([
+- #include <faad.h>
+- #include <stdio.h>
+- main()
+- {
+- int faad_major;
+- int faad_minor;
+- faacDecHandle dec;
+-
+- if(sscanf(FAAD2_VERSION, "%d.%d", &faad_major, &faad_minor) < 2)
+- return -1;
+- dec = faacDecOpen();
+- if(!dec)
+- return -1;
+- return 0;
+- }
+- ],
+- [
+- # program could be run
+- have_faad2="true"
+- AC_MSG_RESULT(yes)
+- FAAD2_CFLAGS=$CFLAGS
+- FAAD2_LIBS=$LIBS
+-
+-
+- ],
+- # program could not be run
+- AC_MSG_RESULT(no)
+-)
+-
+-fi
+-
+-CFLAGS=$OLD_CFLAGS
+-LIBS=$OLD_LIBS
+
+ fi
+