summaryrefslogtreecommitdiffstats
path: root/libraries/LucenePlusPlus/LuceneHeaders.patch
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-06-01 22:03:27 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-06-05 06:19:06 +0700
commitec43977fdfcf38bcb44b667afe48f0ab744b6682 (patch)
tree09c95fd286d69b7addc1d5a2e2f9094b945e3510 /libraries/LucenePlusPlus/LuceneHeaders.patch
parent30d9448d938bb3a2b134b439219302f9239d04b3 (diff)
downloadslackbuilds-ec43977fdfcf38bcb44b667afe48f0ab744b6682.tar.gz
slackbuilds-ec43977fdfcf38bcb44b667afe48f0ab744b6682.tar.xz
libraries/LucenePlusPlus: Added (text search engine)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'libraries/LucenePlusPlus/LuceneHeaders.patch')
-rw-r--r--libraries/LucenePlusPlus/LuceneHeaders.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/libraries/LucenePlusPlus/LuceneHeaders.patch b/libraries/LucenePlusPlus/LuceneHeaders.patch
new file mode 100644
index 0000000000..4ff60c5d20
--- /dev/null
+++ b/libraries/LucenePlusPlus/LuceneHeaders.patch
@@ -0,0 +1,38 @@
+commit 994f03cf736229044a168835ae7387696041658f
+Author: rezso <rezso@example.com>
+Date: Mon May 19 09:20:40 2014 +0100
+
+ fix installing lucene++ headers in 3.0.6
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b0f3f20..6ae96b7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -138,6 +138,14 @@ if(NOT WIN32)
+ DESTINATION "${LIB_DESTINATION}/pkgconfig")
+ endif()
+
++#################################
++# install Config.h
++#################################
++install(
++ FILES
++ "${CMAKE_CURRENT_BINARY_DIR}/include/Config.h"
++ DESTINATION include/lucene++)
++
+ ####################################
+ # custom targets
+ ####################################
+diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
+index 83eb578..7d6153d 100644
+--- a/src/core/CMakeLists.txt
++++ b/src/core/CMakeLists.txt
+@@ -20,7 +20,7 @@ file(GLOB_RECURSE lucene_internal_headers
+ )
+
+ file(GLOB_RECURSE lucene_headers
+- include/*.h
++ "${lucene++_SOURCE_DIR}/include/*.h"
+ )
+
+ add_definitions(-DLPP_BUILDING_LIB)