summaryrefslogtreecommitdiffstats
path: root/libraries/BTF/autotoolize.diff
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2013-11-25 02:22:30 -0600
committer Robby Workman <rworkman@slackbuilds.org>2014-01-31 00:53:56 -0600
commita953dce0103e3053aa98c01fdac58303c240fc75 (patch)
treed016c3c700877134b2af449fc11d2b613dc6d4c5 /libraries/BTF/autotoolize.diff
parentc845df2863f3ece2a7d24f5517a7956a4a2c7505 (diff)
downloadslackbuilds-a953dce0103e3053aa98c01fdac58303c240fc75.tar.gz
slackbuilds-a953dce0103e3053aa98c01fdac58303c240fc75.tar.xz
libraries/BTF: Updated for version 1.2.0.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to '')
-rw-r--r--libraries/BTF/autotoolize.diff36
1 files changed, 24 insertions, 12 deletions
diff --git a/libraries/BTF/autotoolize.diff b/libraries/BTF/autotoolize.diff
index bc9756efab..29d555f8d1 100644
--- a/libraries/BTF/autotoolize.diff
+++ b/libraries/BTF/autotoolize.diff
@@ -3,8 +3,8 @@ new file mode 100644
--- /dev/null
+++ b/Include/Makefile.am
@@ -0,0 +1,2 @@
-+pkgincludedir = $(includedir)/btf
-+pkginclude_HEADERS = btf.h btf_internal.h
++pkginclude_HEADERS = btf.h
++noinst_HEADERS = btf_internal.h
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
@@ -20,7 +20,7 @@ new file mode 100644
--- /dev/null
+++ b/Source/Makefile.am
@@ -0,0 +1,18 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include $(UFCONFIG_CFLAGS)
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
+
+BTFSRC = \
+ btf_maxtrans.c \
@@ -37,12 +37,12 @@ new file mode 100644
+
+libbtf_la_SOURCES =
+libbtf_la_LIBADD = libbtfi.la libbtfl.la
-+libbtf_la_LDFLAGS = -no-undefined -version-info 2:2:1
++libbtf_la_LDFLAGS = -no-undefined -version-number 1:2:0
diff --git a/btf.pc.in b/btf.pc.in
new file mode 100644
--- /dev/null
+++ b/btf.pc.in
-@@ -0,0 +1,11 @@
+@@ -0,0 +1,12 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
@@ -51,28 +51,40 @@ new file mode 100644
+Name: @PACKAGE_NAME@
+Description: Permutation to block triangular form
+Version: @PACKAGE_VERSION@
-+Requires.private: ufconfig
++URL: @PACKAGE_URL@
++Requires.private: suitesparseconfig
+Libs: -L${libdir} -lbtf
+Cflags: -I${includedir}/btf
diff --git a/configure.ac b/configure.ac
new file mode 100644
--- /dev/null
+++ b/configure.ac
-@@ -0,0 +1,21 @@
-+AC_PREREQ([2.68])
-+AC_INIT([BTF],[1.1.2],[davis@cise.ufl.edu])
+@@ -0,0 +1,32 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ([2.69])
++AC_INIT([BTF],[1.2.0],[DrTimothyAldenDavis@gmail.com],[btf],[http://www.suitesparse.com/])
+AC_CONFIG_SRCDIR([Source/btf_order.c])
-+AC_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign])
+LT_INIT
+
++# Checks for programs.
+AC_PROG_INSTALL
+AC_PROG_CC
+
++# Checks for libraries.
+PKG_PROG_PKG_CONFIG
-+PKG_CHECK_MODULES([UFCONFIG],[ufconfig],
++PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
+ [],
-+ [AC_MSG_ERROR([cannot find ufconfig])])
++ [AC_MSG_ERROR([cannot find suitesparseconfig])])
++
++# Checks for header files.
++
++# Checks for typedefs, structures, and compiler characteristics.
++
++# Checks for library functions.
+
+AC_CONFIG_FILES([
+ btf.pc