summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Daniel Prosser <dpross1100@msn.com>2023-02-13 09:54:10 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-02-18 10:06:43 +0700
commit7e509903499397513609c7223b24f415f0ae9c8b (patch)
tree78bae972781cda0c27f06fcad978faff4f0577f6 /graphics
parent4a54f090deaf93deecbc0d41382972b7b56af348 (diff)
downloadslackbuilds-7e509903499397513609c7223b24f415f0ae9c8b.tar.gz
slackbuilds-7e509903499397513609c7223b24f415f0ae9c8b.tar.xz
graphics/ART: Updated for version 1.18.1.
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ART/ART.SlackBuild8
-rw-r--r--graphics/ART/ART.info6
-rw-r--r--graphics/ART/disable_mimalloc.patch11
3 files changed, 20 insertions, 5 deletions
diff --git a/graphics/ART/ART.SlackBuild b/graphics/ART/ART.SlackBuild
index 75b435a90f..7097fce5ba 100644
--- a/graphics/ART/ART.SlackBuild
+++ b/graphics/ART/ART.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ART
-# Copyright 2022 Daniel Prosser, Lexington Park, MD
+# Copyright 2023 Daniel Prosser, Lexington Park, MD
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ART
-VERSION=${VERSION:-1.17.2}
+VERSION=${VERSION:-1.18.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,6 +76,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# lensfun-0.3.95 segfaults with mimalloc. Version 0.3.3 solves the issue, but
+# we need to wait until Slackware-15.1 for that.
+patch -p0 < $CWD/disable_mimalloc.patch
+
mkdir -p build
cd build
cmake \
diff --git a/graphics/ART/ART.info b/graphics/ART/ART.info
index 9d0e4414b0..d6d4787062 100644
--- a/graphics/ART/ART.info
+++ b/graphics/ART/ART.info
@@ -1,8 +1,8 @@
PRGNAM="ART"
-VERSION="1.17.2"
+VERSION="1.18.1"
HOMEPAGE="https://bitbucket.org/agriggio/art/wiki/Home"
-DOWNLOAD="https://bitbucket.org/agriggio/art/downloads/ART-1.17.2.tar.xz"
-MD5SUM="65d9d859a9bc113960827b6e83c88090"
+DOWNLOAD="https://bitbucket.org/agriggio/art/downloads/ART-1.18.1.tar.xz"
+MD5SUM="59040eb1a35639ec09404fe1085c77b2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/graphics/ART/disable_mimalloc.patch b/graphics/ART/disable_mimalloc.patch
new file mode 100644
index 0000000000..c77763ed12
--- /dev/null
+++ b/graphics/ART/disable_mimalloc.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt 2023-01-16 02:54:14.000000000 -0500
++++ CMakeLists.txt.new 2023-02-10 23:26:49.042916996 -0500
+@@ -606,8 +606,6 @@
+ add_definitions(-DWITH_MIMALLOC)
+ set(ART_MIMALLOC_VERSION_INFO "V${mimalloc_VERSION}")
+ endif()
+-else()
+- message(FATAL_ERROR "ART requires the mimalloc library. Please install it (see https://microsoft.github.io/mimalloc/)")
+ endif()
+
+ if(ENABLE_LIBRAW)