summaryrefslogtreecommitdiffstats
path: root/graphics/screencloud/010-screencloud-fix-python-link-libraries.patch
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2022-02-05 18:07:07 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-06 15:47:06 +0700
commit4139712fe9c3356de0471c85cd4977a9acb54a33 (patch)
tree724733a43f3929f30149d31b5dc1521e45c3b8f1 /graphics/screencloud/010-screencloud-fix-python-link-libraries.patch
parentdb2f27c40e294f9a4528a10310db9f57c458ef1f (diff)
downloadslackbuilds-4139712fe9c3356de0471c85cd4977a9acb54a33.tar.gz
slackbuilds-4139712fe9c3356de0471c85cd4977a9acb54a33.tar.xz
graphics/screencloud: Updated for version 1.5.3, build from source.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/screencloud/010-screencloud-fix-python-link-libraries.patch')
-rw-r--r--graphics/screencloud/010-screencloud-fix-python-link-libraries.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/graphics/screencloud/010-screencloud-fix-python-link-libraries.patch b/graphics/screencloud/010-screencloud-fix-python-link-libraries.patch
new file mode 100644
index 0000000000..7dde6e1257
--- /dev/null
+++ b/graphics/screencloud/010-screencloud-fix-python-link-libraries.patch
@@ -0,0 +1,38 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -263,17 +263,6 @@ set(REQUIRED_LIBS ${REQUIRED_LIBS}
+ ${QUAZIP_LIBRARY}
+ )
+
+-#Find Python
+-if(PYTHON_USE_PYTHON3)
+- find_package(PythonLibs 3.3 REQUIRED)
+-else(PYTHON_USE_PYTHON3)
+- find_package(PythonLibs 2.6 REQUIRED)
+-endif(PYTHON_USE_PYTHON3)
+-include_directories(${PYTHON_INCLUDE_DIR})
+-set(REQUIRED_LIBS ${REQUIRED_LIBS}
+- ${PYTHON_LIBRARIES}
+-)
+-
+ #Find PythonQt
+ find_package(PythonQt REQUIRED)
+ include_directories(${PYTHONQT_INCLUDE_DIR})
+@@ -293,6 +282,17 @@ else(PYTHONQT_QTALL_FOUND)
+ message(STATUS "Using PythonQt_QtBindings (old) for Qt bindings.")
+ endif(PYTHONQT_QTALL_FOUND)
+
++#Find Python
++if(PYTHON_USE_PYTHON3)
++ find_package(PythonLibs 3.3 REQUIRED)
++else(PYTHON_USE_PYTHON3)
++ find_package(PythonLibs 2.6 REQUIRED)
++endif(PYTHON_USE_PYTHON3)
++include_directories(${PYTHON_INCLUDE_DIR})
++set(REQUIRED_LIBS ${REQUIRED_LIBS}
++ ${PYTHON_LIBRARIES}
++)
++
+ #Platform specific libs
+ if(WIN32)
+ set(REQUIRED_LIBS ${REQUIRED_LIBS}