summaryrefslogtreecommitdiffstats
path: root/graphics/qiv/new_formats.diff
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2019-12-27 15:01:38 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-12-31 18:06:25 +0700
commit0030076b42dd6011a3215af1c30ebd57d24500b3 (patch)
treef55fb80ff521d08b00d5de0ec929f8f10c02d401 /graphics/qiv/new_formats.diff
parentd452da1a2630e10d633466d8f8f636949b6c71fd (diff)
downloadslackbuilds-0030076b42dd6011a3215af1c30ebd57d24500b3.tar.gz
slackbuilds-0030076b42dd6011a3215af1c30ebd57d24500b3.tar.xz
graphics/qiv: Updated for version 2.3.2, add image formats.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'graphics/qiv/new_formats.diff')
-rw-r--r--graphics/qiv/new_formats.diff62
1 files changed, 62 insertions, 0 deletions
diff --git a/graphics/qiv/new_formats.diff b/graphics/qiv/new_formats.diff
new file mode 100644
index 0000000000..991583586e
--- /dev/null
+++ b/graphics/qiv/new_formats.diff
@@ -0,0 +1,62 @@
+diff -Naur qiv-2.3.2/Makefile qiv-2.3.2.patched/Makefile
+--- qiv-2.3.2/Makefile 2017-11-03 14:27:27.000000000 -0400
++++ qiv-2.3.2.patched/Makefile 2019-12-27 03:28:13.162355379 -0500
+@@ -24,7 +24,7 @@
+ # skipped.) It should reflect whatever is compiled into imlib.
+ # The latest version of imlib has removed imagemagick fallback support,
+ # so some extensions (XBM TGA) have been removed.
+-EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO
++EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP XCF PSD ICNS TGA
+
+ # Comment this line out if your system doesn't have getopt_long().
+ GETOPT_LONG = -DHAVE_GETOPT_LONG
+diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
+--- qiv-2.3.2/main.h 2017-11-03 14:27:27.000000000 -0400
++++ qiv-2.3.2.patched/main.h 2019-12-27 03:23:02.330241315 -0500
+@@ -199,6 +199,24 @@
+ #ifdef EXTN_SVG
+ ".svg",
+ #endif
++#ifdef EXTN_WEBP
++ ".webp",
++#endif
++#ifdef EXTN_XCF
++ ".xcf",
++#endif
++#ifdef EXTN_PSD
++ ".psd",
++#endif
++#ifdef EXTN_ICNS
++ ".icns",
++#endif
++ /* BROKEN in slackware 14.2, using newer versions
++ of jasper and gdk-pixbuf2 built with jasper didn't help.
++ Disabled in Makefile. */
++#ifdef EXTN_JP2
++ ".jp2", ".jpc", ".jpx", ".j2k", ".jpf",
++#endif
+ NULL
+ };
+
+@@ -238,6 +256,21 @@
+ #ifdef EXTN_ICO
+ "MS Windows icon resource",
+ #endif
++#ifdef EXTN_WEBP
++ "RIFF (little-endian) data, Web/P image",
++#endif
++#ifdef EXTN_XCF
++ "GIMP XCF image data",
++#endif
++#ifdef EXTN_PSD
++ "Adobe Photoshop Image",
++#endif
++#ifdef EXTN_ICNS
++ "Mac OS X icon",
++#endif
++#ifdef EXTN_JP2
++ "JPEG 2000",
++#endif
+ NULL
+ };
+ #endif