summaryrefslogtreecommitdiffstats
path: root/graphics/pyformex
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-02-27 02:14:31 -0500
committer Robby Workman <rworkman@slackbuilds.org>2022-02-27 22:27:51 -0600
commit7554509f0df553859a1c660d102f3a6a0d3ae229 (patch)
treea4843ac78d40e421887f92f4c7592e737001098d /graphics/pyformex
parent2c8e4206ef3cdfe9796cb72284268f46da29a2f4 (diff)
downloadslackbuilds-7554509f0df553859a1c660d102f3a6a0d3ae229.tar.gz
slackbuilds-7554509f0df553859a1c660d102f3a6a0d3ae229.tar.xz
graphics/pyformex: Fix 15.0 build.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'graphics/pyformex')
-rw-r--r--graphics/pyformex/pyformex.SlackBuild25
-rw-r--r--graphics/pyformex/pyformex.info4
2 files changed, 18 insertions, 11 deletions
diff --git a/graphics/pyformex/pyformex.SlackBuild b/graphics/pyformex/pyformex.SlackBuild
index 8d6d7beb9c..876b1a07e4 100644
--- a/graphics/pyformex/pyformex.SlackBuild
+++ b/graphics/pyformex/pyformex.SlackBuild
@@ -22,6 +22,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220222 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix build on 15.0.
+# - fix path to icon in .desktop file.
+# - add required runtime dep pyside.
+# - TODO: someone should look at including the pyformex/extra stuff.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pyformex
@@ -38,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,20 +78,24 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# patch for manpage path
sed -i "s/share\/man/man/" manifest.py
+# 20220227 bkw: this moved...
+sed -i 's,/etc/X11/rgb.txt,/usr/share/X11/rgb.txt,' pyformex/gui/__init__.py
+
python setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+sed -i '/Icon/s,=.*,=/usr/share/pixmaps/pyformex-64x64.png,' \
+ $PKG/usr/share/applications/pyformex.desktop
+
+strip $PKG/usr/lib*/python2.7/site-packages/$PRGNAM/lib/*.so
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man*/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING PKG-INFO Description README \
diff --git a/graphics/pyformex/pyformex.info b/graphics/pyformex/pyformex.info
index 73c32d27d6..ad1c584cdd 100644
--- a/graphics/pyformex/pyformex.info
+++ b/graphics/pyformex/pyformex.info
@@ -1,10 +1,10 @@
PRGNAM="pyformex"
VERSION="1.0.5"
HOMEPAGE="http://www.nongnu.org/pyformex/"
-DOWNLOAD="ftp://bumps.ugent.be/pub/pyformex/pyformex-1.0.5.tar.gz"
+DOWNLOAD="https://slackware.uk/~urchlay/src/pyformex-1.0.5.tar.gz"
MD5SUM="5fa1526927c44cf67882195d3f988edd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="PyOpenGL numpy"
+REQUIRES="PyOpenGL numpy pyside"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"