summaryrefslogtreecommitdiffstats
path: root/graphics/fbida/fbida.SlackBuild
diff options
context:
space:
mode:
author Luis Henrique <lmello.009@gmail.com>2013-03-11 19:29:46 -0400
committer dsomero <xgizzmo@slackbuilds.org>2013-03-22 07:16:36 -0400
commite74fcb2cf6dd8010b02e787c0381b15bbe5e9ef8 (patch)
tree2af01342446dde8cb31cacd31cdb924ed9ec4f9e /graphics/fbida/fbida.SlackBuild
parent73b2640c6e0d7c50c14eb5d8d1fb76238d5a8c25 (diff)
downloadslackbuilds-e74fcb2cf6dd8010b02e787c0381b15bbe5e9ef8.tar.gz
slackbuilds-e74fcb2cf6dd8010b02e787c0381b15bbe5e9ef8.tar.xz
graphics/fbida: Updated for version 2.09.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'graphics/fbida/fbida.SlackBuild')
-rw-r--r--graphics/fbida/fbida.SlackBuild16
1 files changed, 3 insertions, 13 deletions
diff --git a/graphics/fbida/fbida.SlackBuild b/graphics/fbida/fbida.SlackBuild
index 3650067367..4e8a7477fc 100644
--- a/graphics/fbida/fbida.SlackBuild
+++ b/graphics/fbida/fbida.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-
-# Slackware build script for fbida
+
+# Slackware build script for fbida
# Modified by Luis Henrique <lmello.009@gmail.com>
# (C) 2007 Michael Wagner <lapinours@web.de>
@@ -24,16 +24,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=fbida
-VERSION=2.07
+VERSION=2.09
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -74,14 +72,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# "Patch" GNUmakefile and mk/Autoconf.mk
-for i in GNUmakefile mk/Autoconf.mk; do
- sed -i s,/X11R6,, $i || exit 1
-done
-
-# Fix rd/read-png.c (obsolete libpng declaration)
-patch -p0 < $CWD/read-png.c.patch
-
CFLAGS="$SLKCFLAGS" make HAVE_MOTIF=no
prefix=/usr make install DESTDIR=$PKG HAVE_MOTIF=no