summaryrefslogtreecommitdiffstats
path: root/games/oolite
diff options
context:
space:
mode:
author Johannes Schoepfer <slackbuilds@schoepfer.info>2022-02-17 12:57:38 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-17 12:57:38 +0700
commit3478ca776dbc102169b3da8fc791b8f4c65a81a4 (patch)
tree111d9c1456e6b57995a47588a4781a090d08380e /games/oolite
parentd6f247f7e703b98e2934eec9172c8735fef422c7 (diff)
downloadslackbuilds-3478ca776dbc102169b3da8fc791b8f4c65a81a4.tar.gz
slackbuilds-3478ca776dbc102169b3da8fc791b8f4c65a81a4.tar.xz
games/oolite: Fix build.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/oolite')
-rw-r--r--games/oolite/oolite.SlackBuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/games/oolite/oolite.SlackBuild b/games/oolite/oolite.SlackBuild
index 9b44ab48a8..3734a5cf98 100644
--- a/games/oolite/oolite.SlackBuild
+++ b/games/oolite/oolite.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for oolite
-# Copyright 2016 - 2020 Johannes Schoepfer, Germany
+# Copyright 2016 - 2022 Johannes Schoepfer, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -68,9 +68,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf oolite-source-$VERSION
-tar vxf $CWD/oolite-source-$VERSION.tar.bz2
-cd oolite-source-$VERSION
+rm -rf $PRGNAM-source-$VERSION
+tar vxf $CWD/$PRGNAM-source-$VERSION.tar.bz2
+cd $PRGNAM-source-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -78,15 +78,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Make sure only system libs may be used
+# Make sure only system libs will be used
rm deps/Linux-deps/x86*/lib/*
+rm -rf deps/Linux-deps/include/*
source /usr/share/GNUstep/Makefiles/GNUstep.sh
export GNUSTEP_MAKEFILES=/usr/share/GNUstep/Makefiles
sed -i \
- -e "/ADDITIONAL_OBJCFLAGS/s/=/= -fobjc-exceptions ${SLKCFLAGS}/" \
+ -e "/ADDITIONAL_OBJCFLAGS/s/=/= ${SLKCFLAGS}/" \
-e "s/-mtune=generic//g" \
- -e "s/ -lpng / -l:libpng14.so.14 /g" \
-e "/ADDITIONAL_OBJC_LIBS/s/+= -lespeak/+= -lespeak-ng/" \
GNUmakefile