summaryrefslogtreecommitdiffstats
path: root/games/ivan/ivan.SlackBuild
diff options
context:
space:
mode:
author hollywoodb <hollywoodb@fastmail.fm>2010-05-11 14:28:19 +0200
committer Erik Hanson <erik@slackbuilds.org>2010-05-11 14:28:19 +0200
commit637edc2a2438d9a1832759e225151790276601ea (patch)
tree1afd6369d135fa44038b2c1f0cf77c6a46f370c2 /games/ivan/ivan.SlackBuild
parentdb40c228c77ed083d37f306efe4a8eefed91785a (diff)
downloadslackbuilds-637edc2a2438d9a1832759e225151790276601ea.tar.gz
slackbuilds-637edc2a2438d9a1832759e225151790276601ea.tar.xz
games/ivan: Initial import
Diffstat (limited to 'games/ivan/ivan.SlackBuild')
-rw-r--r--games/ivan/ivan.SlackBuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/games/ivan/ivan.SlackBuild b/games/ivan/ivan.SlackBuild
new file mode 100644
index 0000000000..b54012f970
--- /dev/null
+++ b/games/ivan/ivan.SlackBuild
@@ -0,0 +1,76 @@
+#!/bin/sh
+
+## Written by hollywoodb (hollywoodb@fastmail.fm)
+
+## Feel free to use, modify, redistribute this script.
+## If you make changes please modify the "Written by"
+## so that I don't recieve emails about a script I
+## did not write. Thanks.
+
+if [ "$(id -u)" != "0" ]; then
+ echo "This script must be run as root!"
+ exit
+fi
+
+NAME=ivan
+VERSION=0.50
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$NAME}
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG $TMP/$NAME-$VERSION
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+tar zxvf $CWD/$NAME-$VERSION.tar.gz || exit 1
+cd $NAME-$VERSION || exit 1
+
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+# Fix Makefile.in so that it does mkdir, chown, and chmod within
+# DESTDIR like it is supposed to. Also fix own/perm settings on
+# /usr/games/ivan executable
+patch -p0 < $CWD/Makefile.in-install.patch || exit 1
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/games \
+ --datadir=/usr/share/games \
+ --libdir=/usr/lib/games \
+ --sysconfdir=/etc \
+ --localstatedir=/var/games \
+ || exit 1
+
+make || exit 1
+make install DESTDIR=$PKG || exit 1
+
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+install -m 0644 $CWD/$NAME.desktop $PKG/usr/share/applications/$NAME.desktop
+install -m 0644 $CWD/$NAME.png $PKG/usr/share/pixmaps/
+
+find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir -p $PKG/usr/doc/$NAME-$VERSION
+cp -a {AUTHORS,COPYING,ChangeLog,LICENSING,INSTALL} $PKG/usr/doc/$NAME-$VERSION
+chmod -x $PKG/usr/doc/$NAME-$VERSION/*
+cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n -p $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.tgz