summaryrefslogtreecommitdiffstats
path: root/games/bsnes/bsnes.SlackBuild
diff options
context:
space:
mode:
author Erik Hanson <erik@slackbuilds.org>2012-12-18 16:59:06 -0500
committer dsomero <xgizzmo@slackbuilds.org>2012-12-23 09:16:40 -0500
commit32b4596217a5c9c295a3f1b4743418369dc98829 (patch)
tree99354921da0ba1f8796efea1342c6e69f6ca128c /games/bsnes/bsnes.SlackBuild
parent8f604d4038aa1106562610f18576ea1be467919d (diff)
downloadslackbuilds-32b4596217a5c9c295a3f1b4743418369dc98829.tar.gz
slackbuilds-32b4596217a5c9c295a3f1b4743418369dc98829.tar.xz
games/bsnes: Updated build, new maintainer.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to '')
-rw-r--r--games/bsnes/bsnes.SlackBuild30
1 files changed, 9 insertions, 21 deletions
diff --git a/games/bsnes/bsnes.SlackBuild b/games/bsnes/bsnes.SlackBuild
index f3625a7141..18dc34ae6c 100644
--- a/games/bsnes/bsnes.SlackBuild
+++ b/games/bsnes/bsnes.SlackBuild
@@ -3,10 +3,11 @@
# Slackware build script for bsnes
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Maintained by Erik Hanson <erik@slackbuilds.org>
PRGNAM=bsnes
VERSION=${VERSION:-091}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -52,21 +53,14 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-cd $PRGNAM
-
-sed -e 's|audio.pulseaudio ||' \
- -e 's|audio.pulseaudiosimple ||' \
- -i 'target-ethos/Makefile'
+# apply the patch to allow proper install on slackware as root (from hackedhead)
+patch -p1 -i $CWD/bsnes-v091.patch
+cd $PRGNAM
moc -i -Iphoenix/qt/ -o phoenix/qt/platform.moc phoenix/qt/platform.moc.hpp
-sed -e 's/sudo install/install/' \
- -i 'target-ethos/Makefile'
-# Choose whether qt or gtk interface is used. Qt4 is default.
-if [ "${INTERFACE:-QT4}" != 'QT4' ]; then
- PHOENIX='gtk'
-else
- PHOENIX='qt'
-fi
+
+# Choose whether a qt or gtk interface is built.
+PHOENIX=${PHOENIX:-gtk}
# Determine which mode to build bsnes.
# Possible values for PROFILE: accuracy, compatibility, and performance.
@@ -83,14 +77,11 @@ make \
make install profile=$PROFILE DESTDIR=$PKG prefix=/usr
cd ..
-# Compile snespurify. It helps clean up ROMS for use with bsnes.
+# Compile purify. It helps clean up ROMS for use with bsnes.
cd purify
# Fix building with QT >= 4.8.0.
moc -i -Iphoenix/qt/ -o phoenix/qt/platform.moc phoenix/qt/platform.moc.hpp
-# Fix snespurify scripts.
-sed -e 's|link := -s|link := -s -lX11|' -i 'Makefile'
-
make \
compiler=gcc \
platform=x \
@@ -103,9 +94,6 @@ cd ..
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/share/$PRGNAM/profile
-cp -R bsnes/profile/* $PKG/usr/share/$PRGNAM/profile
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild