summaryrefslogtreecommitdiffstats
path: root/development/xemacs/patches
diff options
context:
space:
mode:
author Sean MacLennan <xemacs@seanm.ca>2011-11-12 00:10:23 -0600
committer Robby Workman <rworkman@slackbuilds.org>2011-11-12 12:17:21 -0600
commit61faa8b74d6fe94a393ac57ab8258933a3c08e6f (patch)
tree4a24a978ffc90fd98db51f0bf03a20b48e9a746e /development/xemacs/patches
parent572042ec89f883d3ba9fd49507437eec4d6858c1 (diff)
downloadslackbuilds-61faa8b74d6fe94a393ac57ab8258933a3c08e6f.tar.gz
slackbuilds-61faa8b74d6fe94a393ac57ab8258933a3c08e6f.tar.xz
development/xemacs: Added (XEmacs editor)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'development/xemacs/patches')
-rw-r--r--development/xemacs/patches/check-features.patch11
-rw-r--r--development/xemacs/patches/dump-paths.patch27
-rw-r--r--development/xemacs/patches/lib64.patch29
-rw-r--r--development/xemacs/patches/mod-shift.patch30
4 files changed, 97 insertions, 0 deletions
diff --git a/development/xemacs/patches/check-features.patch b/development/xemacs/patches/check-features.patch
new file mode 100644
index 0000000000..7da578a4b4
--- /dev/null
+++ b/development/xemacs/patches/check-features.patch
@@ -0,0 +1,11 @@
+--- xemacs-21.4.15/Makefile.in.in.orig 2004-07-09 19:00:27.000000000 -0400
++++ xemacs-21.4.15/Makefile.in.in 2004-07-09 19:00:46.000000000 -0400
+@@ -403,7 +403,7 @@
+ ## all. --cet
+
+ check-features: all
+- ${blddir}/src/${PROGNAME} -batch -l check-features.el
++ ${blddir}/src/${PROGNAME} -batch -l ${blddir}/lisp/check-features.el
+
+ install-only: ${MAKE_SUBDIR} check-features install-arch-dep install-arch-indep
+
diff --git a/development/xemacs/patches/dump-paths.patch b/development/xemacs/patches/dump-paths.patch
new file mode 100644
index 0000000000..d5278013d8
--- /dev/null
+++ b/development/xemacs/patches/dump-paths.patch
@@ -0,0 +1,27 @@
+Subject: Re: Compiling XEmacs when same version is already installed
+From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
+Date: 31 Jul 2001 20:23:42 +0200
+http://list-archive.xemacs.org/xemacs/200108/msg00001.html
+
+--- xemacs-21.4.4/lisp/dump-paths.el.orig Tue Jul 31 19:47:56 2001
++++ xemacs-21.4.4/lisp/dump-paths.el Tue Jul 31 19:56:14 2001
+@@ -58,10 +58,18 @@
+ late-packages late-package-load-path)
+ 'external-debugging-output)))
+
+- (setq lisp-directory (paths-find-lisp-directory roots))
++ (let ((build-root (expand-file-name ".." invocation-directory)))
++ (setq lisp-directory (expand-file-name "lisp" build-root))
++ (setq module-directory (expand-file-name "modules" build-root)))
++
+ (if debug-paths
+ (princ (format "lisp-directory:\n%S\n" lisp-directory)
+ 'external-debugging-output))
++
++ (if debug-paths
++ (princ (format "module-directory:\n%S\n" module-directory)
++ 'external-debugging-output))
++
+ (if (featurep 'mule)
+ (progn
+ (setq mule-lisp-directory
diff --git a/development/xemacs/patches/lib64.patch b/development/xemacs/patches/lib64.patch
new file mode 100644
index 0000000000..41f985bd43
--- /dev/null
+++ b/development/xemacs/patches/lib64.patch
@@ -0,0 +1,29 @@
+--- xemacs-21.4.22/lisp/find-paths.el.orig 2011-08-05 13:42:44.545564371 -0400
++++ xemacs-21.4.22/lisp/find-paths.el 2011-08-05 13:43:10.205459415 -0400
+@@ -103,7 +103,7 @@
+ (or
+ ;; installed
+ (paths-file-readable-directory-p (paths-construct-path (list directory
+- "lib"
++ "lib64"
+ emacs-program-name)))
+ ;; in-place or windows-nt
+ (and
+@@ -216,7 +216,7 @@
+ (paths-find-emacs-directory roots
+ (file-name-as-directory
+ (paths-construct-path (list
+- "lib"
++ "lib64"
+ emacs-program-name)))
+ base
+ envvar default
+@@ -230,7 +230,7 @@
+ (paths-find-emacs-directory roots
+ (file-name-as-directory
+ (paths-construct-path
+- (list "lib"
++ (list "lib64"
+ (construct-emacs-version-name))))
+ base
+ envvar default
diff --git a/development/xemacs/patches/mod-shift.patch b/development/xemacs/patches/mod-shift.patch
new file mode 100644
index 0000000000..9ca292a7ef
--- /dev/null
+++ b/development/xemacs/patches/mod-shift.patch
@@ -0,0 +1,30 @@
+--- xemacs-21.4.15/src/event-Xt.c.orig 2004-07-09 11:02:02.000000000 -0400
++++ xemacs-21.4.15/src/event-Xt.c 2004-07-09 11:02:23.000000000 -0400
+@@ -1253,7 +1253,26 @@
+ KeySym bot = XLookupKeysym (ev, Mode_switch_p ? 2 : 0);
+ KeySym top = XLookupKeysym (ev, Mode_switch_p ? 3 : 1);
+ if (top && bot && top != bot)
+- modifiers &= ~XEMACS_MOD_SHIFT;
++ // SAM
++ switch(top) {
++ case 0x1008fe01:
++ case 0x1008fe02:
++ case 0x1008fe03:
++ case 0x1008fe04:
++ case 0x1008fe05:
++ case 0x1008fe06:
++ case 0x1008fe07:
++ case 0x1008fe08:
++ case 0x1008fe09:
++ case 0x1008fe0a:
++ case 0x1008fe0b:
++ case 0x1008fe0c:
++ break;
++ default:
++ modifiers &= ~XEMACS_MOD_SHIFT;
++ break;
++ }
++ //SAM
+ }
+ emacs_event->event_type = key_press_event;
+ emacs_event->timestamp = ev->time;