summaryrefslogtreecommitdiffstats
path: root/development/python3-numpy/python3-numpy.SlackBuild
diff options
context:
space:
mode:
author Christoph Willing <chris.willing@linux.com>2023-06-30 10:02:08 +1000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-02 23:21:23 +0700
commit45a9ec5fb2a26f5892a84c51cb7aa1a12fff99d8 (patch)
tree800cc8d19185e23fd0c76beb8410da7823a54948 /development/python3-numpy/python3-numpy.SlackBuild
parentb7461df7b7872e1711a8bf67b5db0802a8b79609 (diff)
downloadslackbuilds-45a9ec5fb2a26f5892a84c51cb7aa1a12fff99d8.tar.gz
slackbuilds-45a9ec5fb2a26f5892a84c51cb7aa1a12fff99d8.tar.xz
development/python3-numpy: Tidy up
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to '')
-rw-r--r--development/python3-numpy/python3-numpy.SlackBuild30
1 files changed, 12 insertions, 18 deletions
diff --git a/development/python3-numpy/python3-numpy.SlackBuild b/development/python3-numpy/python3-numpy.SlackBuild
index 483a2ad5c1..d72939ed4d 100644
--- a/development/python3-numpy/python3-numpy.SlackBuild
+++ b/development/python3-numpy/python3-numpy.SlackBuild
@@ -1,8 +1,8 @@
#!/bin/bash
-# Slackware build script for numpy3
+# Slackware build script for python3-numpy
-# Copyright 2015-2022 Christoph Willing Brisbane, Australia
+# Copyright 2015-2023 Christoph Willing Brisbane, Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -34,8 +34,6 @@ BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-PYTHON_VERSIONS="3"
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -124,22 +122,18 @@ case "$DEBUG" in
*) DEBUG="" ;;
esac
-for v in $PYTHON_VERSIONS ; do
- if [ $(which python$v 2>/dev/null) ]; then
- if [ ! "$DEBUG" ]; then
- NPY_RELAXED_STRIDES_CHECKING=${NPY_RSC:-1} python$v setup.py install --root $PKG
-
- find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- else
- NPY_RELAXED_STRIDES_CHECKING=${NPY_RSC:-1} python$v setup.py build --debug
- python$v setup.py install --root $PKG
- fi
- fi
-done
+if [ ! "$DEBUG" ]; then
+ NPY_RELAXED_STRIDES_CHECKING=${NPY_RSC:-1} python3 setup.py install --root $PKG
+
+ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+else
+ NPY_RELAXED_STRIDES_CHECKING=${NPY_RSC:-1} python3 setup.py build --debug
+ python3 setup.py install --root $PKG
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.txt THANKS.txt INSTALL.rst.txt PKG-INFO \
+cp -a INSTALL.rst.txt LICENSE.txt README.md THANKS.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc -type f -exec chmod 0644 {} \;