summaryrefslogtreecommitdiffstats
path: root/development/kforth/Makefile.diff
diff options
context:
space:
mode:
author G. Schoenmakers <gschoen@iinet.net.au>2013-02-23 23:00:15 -0600
committer Robby Workman <rworkman@slackbuilds.org>2013-02-23 23:00:15 -0600
commitd34c34353b70a31ab7756d48a4e9fad87eb5d56c (patch)
tree79784551730938410a5e429e9962fa021c55827e /development/kforth/Makefile.diff
parent86ef446c7f9f2b8ae76917b6837f2ec9dcec28a0 (diff)
downloadslackbuilds-d34c34353b70a31ab7756d48a4e9fad87eb5d56c.tar.gz
slackbuilds-d34c34353b70a31ab7756d48a4e9fad87eb5d56c.tar.xz
development/kforth: Added (A Forth programming language and environment)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'development/kforth/Makefile.diff')
-rw-r--r--development/kforth/Makefile.diff48
1 files changed, 48 insertions, 0 deletions
diff --git a/development/kforth/Makefile.diff b/development/kforth/Makefile.diff
new file mode 100644
index 0000000000..8223cc7742
--- /dev/null
+++ b/development/kforth/Makefile.diff
@@ -0,0 +1,48 @@
+Index: Makefile
+===================================================================
+--- Makefile (revision 7)
++++ Makefile (working copy)
+@@ -31,6 +31,9 @@
+ # 2011-03-05 km; revised archive and snapshot rules to exclude version
+ # control subdirectories in the archive files (since we
+ # now using Subversion for source control)
++# 2011-03-10 km; define name of environment variable containing default
++# Forth source directory, and pass to compiler.
++# 2011-11-01 km; updated version to 1.5.2p1
+ #
+ # Possible invocations:
+ #
+@@ -50,7 +53,8 @@
+ # Invoke "make debug" if you want to create an executable
+ # that contains debugging information for the GNU debugger (gdb).
+
+-VERSION = 1.5.2
++VERSION = 1.5.2p1
++DEF_DIR_VAR=KFORTH_DIR
+ BUILD_DATE=`date +%F`
+ DEBUG =
+ TARGET_CPU = x86
+@@ -64,7 +68,7 @@
+
+ CPP = ${GCCDIR}/g++
+ CC = ${GCCDIR}/gcc
+-CPPFLAGS = -c -m32
++CPPFLAGS = -c -m32
+ CFLAGS = -c -m32
+ FAST = -D__FAST__
+ OBJS = kforth.o ForthVM.o ForthCompiler.o vm.o vmc.o
+@@ -118,10 +122,12 @@
+ ${CPP} ${CPPFLAGS} ${DEBUG} ForthCompiler.cpp
+
+ ForthVM.o: ForthVM.cpp ForthVM.h fbc.h ForthCompiler.h kfmacros.h
+- ${CPP} ${CPPFLAGS} ${DEBUG} ForthVM.cpp
++ ${CPP} ${CPPFLAGS} -DDIR_ENV_VAR=\"${DEF_DIR_VAR}\" \
++ ${DEBUG} ForthVM.cpp
+
+ ForthVM-fast.o: ForthVM.cpp ForthVM.h fbc.h ForthCompiler.h kfmacros.h
+- ${CPP} ${CPPFLAGS} ${DEBUG} ${FAST} -o ForthVM-fast.o ForthVM.cpp
++ ${CPP} ${CPPFLAGS} -DDIR_ENV_VAR=\"${DEF_DIR_VAR}\" \
++ ${DEBUG} ${FAST} -o ForthVM-fast.o ForthVM.cpp
+
+ vmc.o: vmc.c kfmacros.h
+ ${CC} ${CFLAGS} ${DEBUG} vmc.c