summaryrefslogtreecommitdiffstats
path: root/development/ipython/ipython.SlackBuild
diff options
context:
space:
mode:
author Carlos Corbacho <carlos@strangeworlds.co.uk>2010-05-11 22:53:32 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 22:53:32 +0200
commit8185df7f6b133e9f2ad36d37a9117a05c9aa8e97 (patch)
tree96f577aba0617dcbc973389d87c05bc7d486fe1a /development/ipython/ipython.SlackBuild
parenta482db8c57b19dee1b9fa8f673cd8d350455ef9d (diff)
downloadslackbuilds-8185df7f6b133e9f2ad36d37a9117a05c9aa8e97.tar.gz
slackbuilds-8185df7f6b133e9f2ad36d37a9117a05c9aa8e97.tar.xz
development/ipython: Added to 12.1 repository
Diffstat (limited to 'development/ipython/ipython.SlackBuild')
-rw-r--r--development/ipython/ipython.SlackBuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/development/ipython/ipython.SlackBuild b/development/ipython/ipython.SlackBuild
new file mode 100644
index 0000000000..99fe0b968d
--- /dev/null
+++ b/development/ipython/ipython.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# SlackBuild for IPython
+
+# Copyright 2008 Carlos Corbacho <carlos AT strangeworlds.co.uk>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PKGNAM=ipython
+VERSION=${VERSION:-0.8.4}
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+
+cd $TMP || exit 1
+rm -rf $PKGNAM-$VERSION
+tar xvf $CWD/$PKGNAM-$VERSION.tar.gz || exit 1
+cd $PKGNAM-$VERSION || exit 1
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py \
+ install \
+ --root="$PKG" \
+ || exit 1
+
+mkdir -p $PKG/usr/doc
+mv $PKG/usr/share/doc/ipython $PKG/usr/doc/ipython-$VERSION
+chmod -R 644 $PKG/usr/doc/$PKGNAM-$VERSION/*
+
+mv $PKG/usr/share/man $PKG/usr
+if [ -d $PKG/usr/man ]; then
+ ( cd $PKG/usr/man
+ for manpagedir in $(find . -type d -name "man*") ; do
+ ( cd $manpagedir
+ for eachpage in $( find . -type l -maxdepth 1) ; do
+ ln -s $( readlink $eachpage ).gz $eachpage.gz
+ rm $eachpage
+ done
+ gzip -9 *.?
+ )
+ done
+ )
+fi
+rm -rf $PKG/usr/share
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+
+# Clean up the extra stuff:
+if [ "$1" = "--cleanup" ]; then
+ rm -rf $TMP/$PKGNAM-$VERSION
+ rm -rf $PKG
+fi