summaryrefslogtreecommitdiffstats
path: root/development/Sphinx
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-12-31 18:07:44 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-06 08:08:44 +0700
commit730bddd70345571a3dd94d3fcf44c0fe1703a646 (patch)
tree7095a13b3899e51cc7afe5bf08ce3d35cc524abc /development/Sphinx
parent6bbcaec7cd3615619d3473c046f8ce12fa31c6e1 (diff)
downloadslackbuilds-730bddd70345571a3dd94d3fcf44c0fe1703a646.tar.gz
slackbuilds-730bddd70345571a3dd94d3fcf44c0fe1703a646.tar.xz
development/Sphinx: Updated for version 5.3.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/Sphinx')
-rw-r--r--development/Sphinx/Sphinx.SlackBuild34
-rw-r--r--development/Sphinx/Sphinx.info6
2 files changed, 14 insertions, 26 deletions
diff --git a/development/Sphinx/Sphinx.SlackBuild b/development/Sphinx/Sphinx.SlackBuild
index 9c3f86f3a7..330564c274 100644
--- a/development/Sphinx/Sphinx.SlackBuild
+++ b/development/Sphinx/Sphinx.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Sphinx
-# Copyright 2023 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2023-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2013 Mikko Värri, Finland
# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
@@ -27,7 +27,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=Sphinx
-VERSION=${VERSION:-4.5.0}
+SRCNAM=Sphinx
+VERSION=${VERSION:-5.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,31 +50,14 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "aarch64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -81,7 +65,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+# lower Pygments required version
+sed -i '/Pygments>=/ s/2.12/2.10.0/' pyproject.toml
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/development/Sphinx/Sphinx.info b/development/Sphinx/Sphinx.info
index e2d298c077..9d05ca57e9 100644
--- a/development/Sphinx/Sphinx.info
+++ b/development/Sphinx/Sphinx.info
@@ -1,8 +1,8 @@
PRGNAM="Sphinx"
-VERSION="4.5.0"
+VERSION="5.3.0"
HOMEPAGE="http://www.sphinx-doc.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/S/Sphinx/Sphinx-4.5.0.tar.gz"
-MD5SUM="ed63e60d798d212c1afdecf8acda690e"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/S/Sphinx/Sphinx-5.3.0.tar.gz"
+MD5SUM="b752f7b0177865a36cbcdcef4ac80cd4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="alabaster imagesize python3-babel snowballstemmer sphinxcontrib-applehelp sphinxcontrib-devhelp sphinxcontrib-htmlhelp sphinxcontrib-jsmath sphinxcontrib-qthelp sphinxcontrib-serializinghtml python-importlib_metadata"