summaryrefslogtreecommitdiffstats
path: root/desktop/lxqt-panel
diff options
context:
space:
mode:
author isaackwy <isaacyu@protonmail.com>2024-01-05 18:55:29 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-07 08:53:30 +0700
commit1e400ffdd7bed873d8fbb1ac561f20a20183930c (patch)
tree9c5bfad60f3e5d3da2c058f1f1fb430a0f8fef5f /desktop/lxqt-panel
parent0e66b0339a40e9c963a90caba7d432e3ffa7834e (diff)
downloadslackbuilds-1e400ffdd7bed873d8fbb1ac561f20a20183930c.tar.gz
slackbuilds-1e400ffdd7bed873d8fbb1ac561f20a20183930c.tar.xz
desktop/lxqt-panel: Explicitly require lxqt-menu-data for compliation
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/lxqt-panel')
-rw-r--r--desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch10
-rw-r--r--desktop/lxqt-panel/lxqt-panel.SlackBuild1
2 files changed, 11 insertions, 0 deletions
diff --git a/desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch b/desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch
index 114c0ecdbc..0230b780c3 100644
--- a/desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch
+++ b/desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch
@@ -1,3 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -42,6 +42,7 @@
+ find_package(KF5WindowSystem ${KF5_MINIMUM_VERSION} REQUIRED)
+ find_package(lxqt ${LXQT_MINIMUM_VERSION} REQUIRED)
+ find_package(lxqt-globalkeys-ui ${LXQT_GLOBALKEYS_MINIMUM_VERSION} REQUIRED)
++find_package(lxqt-menu-data 1.4.1 REQUIRED)
+
+ # Patch Version
+ set(LXQT_PANEL_PATCH_VERSION 0)
--- a/menu/CMakeLists.txt
+++ b/menu/CMakeLists.txt
@@ -8,17 +8,3 @@
diff --git a/desktop/lxqt-panel/lxqt-panel.SlackBuild b/desktop/lxqt-panel/lxqt-panel.SlackBuild
index c4253665b2..3dc8b4d163 100644
--- a/desktop/lxqt-panel/lxqt-panel.SlackBuild
+++ b/desktop/lxqt-panel/lxqt-panel.SlackBuild
@@ -83,6 +83,7 @@ find -L . \
[ ${LIBSYSSTAT:-no} = yes ] && ENABLE_SYSSTAT=YES || ENABLE_SYSSTAT=NO
# lxqt-panel should not install files already included within lxqt-menu-data
+# Also, explicitly set the lxqt-menu-data requirement
patch -p1 < $CWD/lxqt-do_not_require_lxmenu_data.patch
mkdir build