summaryrefslogtreecommitdiffstats
path: root/desktop/lxqt-panel
diff options
context:
space:
mode:
author isaackwy <isaacyu@protonmail.com>2024-01-02 03:07:34 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-02 22:43:17 +0700
commit56cbcd0be0adbc747f668138d952a8f81e092cdf (patch)
tree244c47057df115d7fd0c55572360c22e9a323a87 /desktop/lxqt-panel
parent3c9dd7d66246361ba4b251da61c7f243daf6ceb5 (diff)
downloadslackbuilds-56cbcd0be0adbc747f668138d952a8f81e092cdf.tar.gz
slackbuilds-56cbcd0be0adbc747f668138d952a8f81e092cdf.tar.xz
desktop/lxqt-panel: Do not install files that conflict with lxqt-menu-data
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/lxqt-panel')
-rw-r--r--desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch20
-rw-r--r--desktop/lxqt-panel/lxqt-panel.SlackBuild3
2 files changed, 23 insertions, 0 deletions
diff --git a/desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch b/desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch
new file mode 100644
index 0000000000..114c0ecdbc
--- /dev/null
+++ b/desktop/lxqt-panel/lxqt-do_not_require_lxmenu_data.patch
@@ -0,0 +1,20 @@
+--- a/menu/CMakeLists.txt
++++ b/menu/CMakeLists.txt
+@@ -8,17 +8,3 @@
+ )
+ add_custom_target(desktop_directories_files ALL DEPENDS ${DIRECTORY_FILES})
+ #************************************************
+-
+-install(FILES
+- ${DIRECTORY_FILES}
+- DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/desktop-directories"
+- COMPONENT Runtime
+-)
+-
+-install(FILES
+- lxqt-applications.menu
+- lxqt-applications-compact.menu
+- lxqt-applications-simple.menu
+- DESTINATION "${LXQT_ETC_XDG_DIR}/menus"
+- COMPONENT Runtime
+-)
diff --git a/desktop/lxqt-panel/lxqt-panel.SlackBuild b/desktop/lxqt-panel/lxqt-panel.SlackBuild
index 4ea95a8238..c4253665b2 100644
--- a/desktop/lxqt-panel/lxqt-panel.SlackBuild
+++ b/desktop/lxqt-panel/lxqt-panel.SlackBuild
@@ -82,6 +82,9 @@ find -L . \
# Build with libsysstat as optional dependency (enable System Stats plugin)
[ ${LIBSYSSTAT:-no} = yes ] && ENABLE_SYSSTAT=YES || ENABLE_SYSSTAT=NO
+# lxqt-panel should not install files already included within lxqt-menu-data
+patch -p1 < $CWD/lxqt-do_not_require_lxmenu_data.patch
+
mkdir build
cd build
cmake \