summaryrefslogtreecommitdiffstats
path: root/audio/jkmeter/jkmeter.SlackBuild
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2021-11-29 21:58:10 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-12-04 10:09:06 +0700
commit2fe35f429dffd32f60b502b789b22ad094c0bfe3 (patch)
tree0ea2609627d2b9a2260f08583e8d7b65e6bda5f6 /audio/jkmeter/jkmeter.SlackBuild
parentacc836eb6f7574b1f6ce7bd15cf635d26959b987 (diff)
downloadslackbuilds-2fe35f429dffd32f60b502b789b22ad094c0bfe3.tar.gz
slackbuilds-2fe35f429dffd32f60b502b789b22ad094c0bfe3.tar.xz
audio/jkmeter: New-style icons.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio/jkmeter/jkmeter.SlackBuild')
-rw-r--r--audio/jkmeter/jkmeter.SlackBuild30
1 files changed, 20 insertions, 10 deletions
diff --git a/audio/jkmeter/jkmeter.SlackBuild b/audio/jkmeter/jkmeter.SlackBuild
index ffa5ecfe1a..2e65204bb2 100644
--- a/audio/jkmeter/jkmeter.SlackBuild
+++ b/audio/jkmeter/jkmeter.SlackBuild
@@ -6,13 +6,14 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20211129 bkw: BUILD=2, new-style icons, update Bob Katz link.
# 20201104 bkw: updated for 0.8.0.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jkmeter
VERSION=${VERSION:-0.8.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -24,9 +25,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -64,9 +62,9 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
sed -i \
- -e '/march=native/d' \
- -e "s,-O2 -ffast-math,$SLKCFLAGS," \
- source/Makefile
+ -e '/march=native/d' \
+ -e "s,-O2 -ffast-math,$SLKCFLAGS," \
+ source/Makefile
fi
sed -i 's,pkgconf,pkg-config,' source/Makefile
@@ -74,12 +72,24 @@ sed -i 's,pkgconf,pkg-config,' source/Makefile
make -C source PREFIX=/usr DESTDIR=$PKG all install
strip $PKG/usr/bin/$PRGNAM
-# man page, icon, and .desktop file came from Debian
-mkdir -p $PKG/usr/man/man1 $PKG/usr/share/pixmaps $PKG/usr/share/applications
+# man page and .desktop file came from Debian
+mkdir -p $PKG/usr/man/man1 $PKG/usr/share/applications
gzip -9c $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
-cat $CWD/$PRGNAM.xpm > $PKG/usr/share/pixmaps/$PRGNAM.xpm
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+# the 32x32 icon comes from Debian.
+# the 48x48 icon is the 32x32 one, centered in a 48x48 transparent PNG.
+mkdir -p $PKG/usr/share/icons/hicolor/{32x32,48x48}/apps
+convert $CWD/$PRGNAM.xpm \
+ $PKG/usr/share/icons/hicolor/32x32/apps/$PRGNAM.png
+convert -background none -extent 48x48 -gravity center \
+ $CWD/$PRGNAM.xpm \
+ $PKG/usr/share/icons/hicolor/48x48/apps/$PRGNAM.png
+
+mkdir -p $PKG/usr/share/pixmaps
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
+cat $CWD/$PRGNAM.xpm > $PKG/usr/share/pixmaps/$PRGNAM.xpm
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild