summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-05-09 03:04:58 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-13 19:27:32 +0700
commit73defbd204060ae1a88530e1761ad751334b6976 (patch)
tree54ff1ac0177f02a80c9042e6f707d7927d550bf9
parentc92859f8f7e6bce60515062af85b83c5c83ca918 (diff)
downloadslackbuilds-73defbd204060ae1a88530e1761ad751334b6976.tar.gz
slackbuilds-73defbd204060ae1a88530e1761ad751334b6976.tar.xz
development/beautysh: Updated for version 6.2.1, new maintainer.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/beautysh/README9
-rw-r--r--development/beautysh/beautysh.SlackBuild86
-rw-r--r--development/beautysh/beautysh.info12
-rw-r--r--development/beautysh/slack-desc12
4 files changed, 57 insertions, 62 deletions
diff --git a/development/beautysh/README b/development/beautysh/README
index ed34e5c201..adc1f8c2a9 100644
--- a/development/beautysh/README
+++ b/development/beautysh/README
@@ -1,2 +1,7 @@
-This program takes upon itself the hard task of beautifying Bash
-scripts.
+beautysh (beautifier for bash scripts)
+
+beautysh takes upon itself the hard task of beautifying Bash scripts
+(yeesh). Processing Bash scripts is not trivial, they aren't like C or
+Java programs - they have a lot of ambiguous syntax, and (shudder) you
+can use keywords as variables. This means there will be some border
+cases beautysh won't be able to process.
diff --git a/development/beautysh/beautysh.SlackBuild b/development/beautysh/beautysh.SlackBuild
index 87f4fee523..065e036324 100644
--- a/development/beautysh/beautysh.SlackBuild
+++ b/development/beautysh/beautysh.SlackBuild
@@ -2,30 +2,21 @@
# Slackware build script for beautysh
-# Copyright 2018-2020 Leonardo Citrolo, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Originally written by Leonardo Citrolo, Italy
+# Now maintained by B. Watson (urchlay@slackware.uk).
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20230508 bkw:
+# - new maintainer.
+# - relicense as WTFPL with original author's permission.
+# - update for v6.2.1.
+# - expand README and slack-desc
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=beautysh
-VERSION=${VERSION:-6.0.1}
+VERSION=${VERSION:-6.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +29,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,19 +38,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
+LIB=lib
+[ "$ARCH" = "x86_64" ] && LIB=lib64
set -e
@@ -73,18 +50,31 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# For some reason, this requires "poetry", but our package is called
+# poetry-core according to python. *Many* thanks to fourtysixandtwo
+# for pointing this out. Also, there are a couple of bogus
+# not-really-required requirements listed, which prevent the --help
+# and --version options from showing the version number (and make 'pip
+# check' complain).
+sed -i -e '/^requires =/s,"poetry","poetry-core",' \
+ -e '/^types-\(colorama\|setuptools\)/d' \
+ pyproject.toml
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
+
+# Redundant copy of this file (there's another in the right dir).
+rm -f $PKG/usr/lib*/python*/site-packages/LICENSE
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+PYVER=$(pkg-config --modversion python3)
+ln -s ../../$LIB/python$PYVER/site-packages/$PRGNAM-$VERSION.dist-info/LICENSE $PKGDOC
+cp -a README.* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/development/beautysh/beautysh.info b/development/beautysh/beautysh.info
index c0a66b0227..7e89a93e73 100644
--- a/development/beautysh/beautysh.info
+++ b/development/beautysh/beautysh.info
@@ -1,10 +1,10 @@
PRGNAM="beautysh"
-VERSION="6.0.1"
+VERSION="6.2.1"
HOMEPAGE="https://github.com/lovesegfault/beautysh"
-DOWNLOAD="https://github.com/lovesegfault/beautysh/archive/6.0.1/beautysh-6.0.1.tar.gz"
-MD5SUM="8839e2f2a945b83f677f34a2b78ee08a"
+DOWNLOAD="https://github.com/lovesegfault/beautysh/archive/v6.2.1/beautysh-6.2.1.tar.gz"
+MD5SUM="6482b66f1bbddfcb45a341c495434ed1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Leo C."
-EMAIL="leoc@gmx.com"
+REQUIRES="python3-poetry-core colorama"
+MAINTAINER="B. Watson"
+EMAIL="urchlay@slackware.uk"
diff --git a/development/beautysh/slack-desc b/development/beautysh/slack-desc
index b743dd237e..da84bfabc7 100644
--- a/development/beautysh/slack-desc
+++ b/development/beautysh/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-beautysh: beautysh (A Bash beautifier for the masses)
+beautysh: beautysh (beautifier for bash scripts)
beautysh:
-beautysh: This program takes upon itself the hard task of beautifying Bash
-beautysh: scripts.
+beautysh: beautysh takes upon itself the hard task of beautifying Bash scripts
+beautysh: (yeesh). Processing Bash scripts is not trivial, they aren't like C or
+beautysh: Java programs - they have a lot of ambiguous syntax, and (shudder) you
+beautysh: can use keywords as variables. This means there will be some border
+beautysh: cases beautysh won't be able to process.
beautysh:
beautysh:
beautysh:
beautysh:
-beautysh:
-beautysh: Homepage: https://github.com/lovesegfault/beautysh
-beautysh: