summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-05-09 15:12:53 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-13 19:27:32 +0700
commitdd7f78f37ffd38b01e055f4b10f93a5ee0372cba (patch)
treebb23e2e2f2c27aa064fcb40b126d6333771dfd34
parent73defbd204060ae1a88530e1761ad751334b6976 (diff)
downloadslackbuilds-dd7f78f37ffd38b01e055f4b10f93a5ee0372cba.tar.gz
slackbuilds-dd7f78f37ffd38b01e055f4b10f93a5ee0372cba.tar.xz
development/kakoune: Updated for version 2022.10.31, new maintainer.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/kakoune/README6
-rw-r--r--development/kakoune/kakoune.SlackBuild84
-rw-r--r--development/kakoune/kakoune.info10
-rw-r--r--development/kakoune/slack-desc4
4 files changed, 51 insertions, 53 deletions
diff --git a/development/kakoune/README b/development/kakoune/README
index fc306e66a3..3cadd682a3 100644
--- a/development/kakoune/README
+++ b/development/kakoune/README
@@ -1,3 +1,5 @@
-Kakoune is a code editor that implements Vi’s "keystrokes as a text
-editing language" model. As it’s also a modal editor, it's somewhat
+kakoune (text editor)
+
+Kakoune is a code editor that implements Vi's "keystrokes as a text
+editing language" model. As it's also a modal editor, it's somewhat
similar to the Vim editor.
diff --git a/development/kakoune/kakoune.SlackBuild b/development/kakoune/kakoune.SlackBuild
index 59d2fba3a5..5ca8eacb74 100644
--- a/development/kakoune/kakoune.SlackBuild
+++ b/development/kakoune/kakoune.SlackBuild
@@ -2,30 +2,26 @@
# Slackware build script for kakoune
-# Copyright 2018-2020 Leonardo Citrolo, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Oritinally written by Leonardo Citrolo.
+# Now maintained by B. Watson (urchlay@slackware.uk).
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20230509 bkw:
+# - new maintainer.
+# - update for v2022.10.31.
+# - relicense as WTFPL with permission from original author.
+# - override -O3 with $SLKCFLAGS.
+
+# Note: I (B. Watson) took over this build to keep it from
+# disappearing from the repo, but if you actually use and enjoy
+# kakoune, please take the build from me (ask via email). I can't
+# stand to actually use kakoune (tried it, utterly hate it, sorry).
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=kakoune
-VERSION=${VERSION:-2021.11.08}
+VERSION=${VERSION:-2022.10.31}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +34,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -73,28 +66,31 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-CXXFLAGS="$SLKCFLAGS" \
- make -C src PREFIX=/usr
-make -C src install DESTDIR=$PKG \
+rm libexec/kak/kak # dangling symlink
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# N.B. slightly nonstandard use of DESTDIR: we have to include $PKG
+# in docdir and mandir, below.
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+sed -i "s,-O3,$SLKCFLAGS," src/Makefile
+make -C src PREFIX=/usr
+strip src/kak
+make -C src \
PREFIX=/usr \
- docdir=$PKG/usr/doc/$PRGNAM-$VERSION \
- mandir=$PKG/usr/man/man1
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-cp -a CONTRIBUTING UNLICENSE VIMTOKAK \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+ docdir=$PKGDOC \
+ mandir=$PKG/usr/man/man1 \
+ DESTDIR=$PKG \
+ install
+
+# Man page already gzipped, we stripped the binary above. Thought
+# about symlinking all the asciidoc from /usr/share/kak to our doc
+# dir, but it's intended to be read from within kak, with the :doc
+# command.
+
+cp -a CONTRIBUTING UNLICENSE VIMTOKAK $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/development/kakoune/kakoune.info b/development/kakoune/kakoune.info
index e56f01893d..40f588ca50 100644
--- a/development/kakoune/kakoune.info
+++ b/development/kakoune/kakoune.info
@@ -1,10 +1,10 @@
PRGNAM="kakoune"
-VERSION="2021.11.08"
+VERSION="2022.10.31"
HOMEPAGE="https://kakoune.org/"
-DOWNLOAD="https://github.com/mawww/kakoune/releases/download/v2021.11.08/kakoune-2021.11.08.tar.bz2"
-MD5SUM="438acaf83913adb7ce9ce19ec138e8ea"
+DOWNLOAD="https://github.com/mawww/kakoune/releases/download/v2022.10.31/kakoune-2022.10.31.tar.bz2"
+MD5SUM="90f9d42857be192fbb175f8a6e9abd43"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Leo C."
-EMAIL="leoc@gmx.com"
+MAINTAINER="B. Watson"
+EMAIL="urchlay@slackware.uk"
diff --git a/development/kakoune/slack-desc b/development/kakoune/slack-desc
index e7f550b223..b2078aa713 100644
--- a/development/kakoune/slack-desc
+++ b/development/kakoune/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-kakoune: kakoune (Kakoune code editor)
+kakoune: kakoune (text editor)
kakoune:
kakoune: Kakoune is a code editor that implements Vi's "keystrokes as a text
kakoune: editing language" model. As it's also a modal editor, it's somewhat
kakoune: similar to the Vim editor.
kakoune:
+kakoune: Homepage: https://kakoune.org/
kakoune:
kakoune:
kakoune:
-kakoune: Homepage: https://kakoune.org/
kakoune: