summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-15 22:23:58 +0700
committer Robby Workman <rworkman@slackbuilds.org>2021-04-21 19:43:44 -0500
commitf9b1818dee4b9b498b6648efc59f2143bd0cd2ce (patch)
tree794a5bc4a2f91592c7e5acb74d07cce0894938e4
parentaf6d7da24811cda3d8c25d45e0b3abe33d298bb2 (diff)
downloadslackbuilds-f9b1818dee4b9b498b6648efc59f2143bd0cd2ce.tar.gz
slackbuilds-f9b1818dee4b9b498b6648efc59f2143bd0cd2ce.tar.xz
gis/geogig-py: Removed (No maintainer).
-rw-r--r--gis/geogig-py/README3
-rw-r--r--gis/geogig-py/geogig-py.SlackBuild85
-rw-r--r--gis/geogig-py/geogig-py.info10
-rw-r--r--gis/geogig-py/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/gis/geogig-py/README b/gis/geogig-py/README
deleted file mode 100644
index c434f2de9d..0000000000
--- a/gis/geogig-py/README
+++ /dev/null
@@ -1,3 +0,0 @@
-geogig-py is a Python library to use GeoGig designed to provide access to all
-GeoGig functionality, so it can be used to script tasks or as the base library
-for a GeoGig client.
diff --git a/gis/geogig-py/geogig-py.SlackBuild b/gis/geogig-py/geogig-py.SlackBuild
deleted file mode 100644
index 9929fc7605..0000000000
--- a/gis/geogig-py/geogig-py.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for geogig-py
-
-# Copyright 2015 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=geogig-py
-VERSION=${VERSION:-1.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/geogig-py/geogig-py.info b/gis/geogig-py/geogig-py.info
deleted file mode 100644
index 403c0d79e3..0000000000
--- a/gis/geogig-py/geogig-py.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="geogig-py"
-VERSION="1.0"
-HOMEPAGE="https://github.com/boundlessgeo/geogig-py"
-DOWNLOAD="https://pypi.python.org/packages/source/g/geogig-py/geogig-py-1.0.zip"
-MD5SUM="e7fb0dae9cb98f8d57ef3812afedbe53"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="geogig geojson py4j Shapely"
-MAINTAINER="orphaned - no maintainer"
-EMAIL="nobody@nowhere"
diff --git a/gis/geogig-py/slack-desc b/gis/geogig-py/slack-desc
deleted file mode 100644
index fd147070cb..0000000000
--- a/gis/geogig-py/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-geogig-py: geogig-py (Python library for GeoGig)
-geogig-py:
-geogig-py: geogig-py is a Python library to use GeoGig designed to provide access
-geogig-py: to all GeoGig functionality, so it can be used to script tasks or as
-geogig-py: the base library for a GeoGig client.
-geogig-py:
-geogig-py:
-geogig-py:
-geogig-py:
-geogig-py:
-geogig-py: