summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Johannes Schoepfer <slackbuilds@schoepfer.info>2024-08-24 08:20:06 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-08-24 08:54:41 +0700
commitbd56423f8f22a5ff4864e7f36c644bace0bb2e06 (patch)
tree8daf739b6da7c2c1f060db97189f83e9561dd603
parent5a5946ed36bd1632320fe812c7e82a42639b4d1f (diff)
downloadslackbuilds-bd56423f8f22a5ff4864e7f36c644bace0bb2e06.tar.gz
slackbuilds-bd56423f8f22a5ff4864e7f36c644bace0bb2e06.tar.xz
desktop/engrampa: Updated for version 1.28.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to '')
-rw-r--r--desktop/engrampa/engrampa.SlackBuild51
-rw-r--r--desktop/engrampa/engrampa.info8
2 files changed, 37 insertions, 22 deletions
diff --git a/desktop/engrampa/engrampa.SlackBuild b/desktop/engrampa/engrampa.SlackBuild
index 9dc9eb4043..2f737e3a12 100644
--- a/desktop/engrampa/engrampa.SlackBuild
+++ b/desktop/engrampa/engrampa.SlackBuild
@@ -27,7 +27,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=engrampa
-VERSION=${VERSION:-1.28.0}
+VERSION=${VERSION:-1.28.2}
+COMMIT_MATE_SUBMODULES=4074560e3642a53ace07b31baaf3f04c060dcd0b
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -77,6 +78,11 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
+(
+ cd subprojects
+ tar vxf $CWD/mate-submodules-$COMMIT_MATE_SUBMODULES.tar.gz
+ mv mate-submodules-$COMMIT_MATE_SUBMODULES mate-submodules
+)
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -84,27 +90,34 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+# If yelp is not present don't build Help-files, remove HelpContents
+# menuitem and move HelpAbout menuitem into file-menu
+if ! command -v yelp; then
+ sed -i "/subdir('help')/d" meson.build
+ sed -i src/ui/menus-toolbars.ui \
+ -e "/menu_icon_help/,+4d"
+fi
+
# Autodetect caja extension
pkg-config libcaja-extension && CAJA="enable" || CAJA="disable"
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-debug=no \
- --disable-schemas-compile \
- --enable-magic \
- --disable-packagekit \
- --${CAJA}-caja-actions \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ unshare -n meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Db_lto=true \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/desktop/engrampa/engrampa.info b/desktop/engrampa/engrampa.info
index 7af2feb64e..45505423d6 100644
--- a/desktop/engrampa/engrampa.info
+++ b/desktop/engrampa/engrampa.info
@@ -1,8 +1,10 @@
PRGNAM="engrampa"
-VERSION="1.28.0"
+VERSION="1.28.2"
HOMEPAGE="https://wiki.mate-desktop.org/mate-desktop/applications/engrampa/"
-DOWNLOAD="https://pub.mate-desktop.org/releases/1.28/engrampa-1.28.0.tar.xz"
-MD5SUM="06673c95793c822486f2a0fa74fb2651"
+DOWNLOAD="https://pub.mate-desktop.org/releases/1.28/engrampa-1.28.2.tar.xz \
+ https://github.com/mate-desktop/mate-submodules/archive/4074560/mate-submodules-4074560e3642a53ace07b31baaf3f04c060dcd0b.tar.gz"
+MD5SUM="5a9e58842f019eddaa30d9fa85c7e957 \
+ 548167f5f5a3c9785150a582e043b06f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""