summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-05-15 22:19:56 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:40 +0700
commit45cf8f35443bcfc3fa720e56db6ab769c2bcbe3f (patch)
tree02809630765b3e64c117c52f2f3cd02a299acbcc
parentd167a1d0be59ad5286a9af7919135ce3ef09d828 (diff)
downloadslackbuilds-45cf8f35443bcfc3fa720e56db6ab769c2bcbe3f.tar.gz
slackbuilds-45cf8f35443bcfc3fa720e56db6ab769c2bcbe3f.tar.xz
python/vine: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to '')
-rw-r--r--python/vine/vine.SlackBuild21
1 files changed, 7 insertions, 14 deletions
diff --git a/python/vine/vine.SlackBuild b/python/vine/vine.SlackBuild
index 720cbbe577..7d3369c571 100644
--- a/python/vine/vine.SlackBuild
+++ b/python/vine/vine.SlackBuild
@@ -40,15 +40,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -63,18 +60,14 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
- # Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
-fi
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
+
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION